Skip to content

← Actionable
High, CVSS 7.5amended

React Server Components have multiple Denial of Service Vulnerabilities

CVE-2026-23864GHSA-83fc-fqcc-2hmg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-server-dom-turbopack 19.2.4, 19.1.5, 19.0.4; react-server-dom-parcel 19.2.4, 19.1.5, 19.0.4; react-server-dom-webpack 19.2.4, 19.1.5, 19.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-server-dom-turbopack

    Affected
    >= 19.1.0-canary-7130d0c6-20241212, < 19.1.5>= 19.0.0, < 19.0.4>= 19.2.0-canary-63779030-20250328, < 19.2.4
    Fixed in
    19.0.4, 19.1.5, 19.2.4
  • npm react-server-dom-parcel

    Affected
    >= 19.0.0, < 19.0.4>= 19.1.0-canary-7130d0c6-20241212, < 19.1.5>= 19.2.0-canary-63779030-20250328, < 19.2.4
    Fixed in
    19.0.4, 19.1.5, 19.2.4
  • npm react-server-dom-webpack

    Affected
    >= 19.2.0-canary-63779030-20250328, < 19.2.4>= 19.1.0-canary-7130d0c6-20241212, < 19.1.5>= 19.0.0, < 19.0.4
    Fixed in
    19.0.4, 19.1.5, 19.2.4

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-83fc-fqcc-2hmg lists affected ranges: npm react-server-dom-parcel >=19.0.0 =19.1.0-canary-7130d0c6-20241212 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 =19.0.0 =19.2.0-canary-63779030-20250328 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 <19.1.5…

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-83fc-fqcc-2hmg lists affected ranges: npm react-server-dom-parcel >=19.0.0 =19.1.0-canary-7130d0c6-20241212 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 =19.0.0 =19.2.0-canary-63779030-20250328 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 =19.0.0 <19.0.4

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-23864: 2.58% estimated exploitation activity in the next 30 days; percentile 85.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It was found that the fixes to address DoS in React Server Components were incomplete and we found multiple denial of service vulnerabilities still exist in React Server Components. We recommend updating immediately. The vulnerability exists in versions 19.0.0, 19.0.1, 19.0.2, 19.0.3, 19.1.0, 19.1.1, 19.1.2, 19.1.3, 19.1.4, 19.2.0, 19.2.1, 19.2.2, 19.2.3 of: - react-server-dom-webpack - react-server-dom-parcel - react-server-dom-turbopack The vulnerabilities are triggered by sending specially crafted HTTP requests to Server Function endpoints, and could lead to server crashes, out-of-memory exceptions or excessive CPU usage; depending on the vulnerable code path being exercised, the application configuration and application code. Patches Fixes were back ported to versions 19.0.4, 19.1.5, and 19.2.4. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-83fc-fqcc-2hmg

  2. Revision 1 · created ·

    Published from osv record GHSA-83fc-fqcc-2hmg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23864

Advisory: React Server Components have multiple Denial of Service Vulnerabilities
IDs: CVE-2026-23864, GHSA-83fc-fqcc-2hmg
Record: https://patchnext.com/advisories/cve-2026-23864 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-server-dom-turbopack 19.2.4, 19.1.5, 19.0.4; react-server-dom-parcel 19.2.4, 19.1.5, 19.0.4; react-server-dom-webpack 19.2.4, 19.1.5, 19.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-server-dom-turbopack: affected >= 19.1.0-canary-7130d0c6-20241212, < 19.1.5; >= 19.0.0, < 19.0.4; >= 19.2.0-canary-63779030-20250328, < 19.2.4; fixed in 19.0.4, 19.1.5, 19.2.4
- npm react-server-dom-parcel: affected >= 19.0.0, < 19.0.4; >= 19.1.0-canary-7130d0c6-20241212, < 19.1.5; >= 19.2.0-canary-63779030-20250328, < 19.2.4; fixed in 19.0.4, 19.1.5, 19.2.4
- npm react-server-dom-webpack: affected >= 19.2.0-canary-63779030-20250328, < 19.2.4; >= 19.1.0-canary-7130d0c6-20241212, < 19.1.5; >= 19.0.0, < 19.0.4; fixed in 19.0.4, 19.1.5, 19.2.4

## Suggested inspection (read-only)
- `npm ls react-server-dom-turbopack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls react-server-dom-parcel --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls react-server-dom-webpack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-server-dom-turbopack, react-server-dom-parcel, react-server-dom-webpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-83fc-fqcc-2hmg (OSV record GHSA-83fc-fqcc-2hmg lists affected ranges: npm react-server-dom-parcel >=19.0.0 =19.1.0-canary-7130d0c6-20241212 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 =19.0.0 =19.2.0-canary-63779030-20250328 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 <19.1.5…)
- Verified: https://github.com/advisories/GHSA-83fc-fqcc-2hmg (GitHub-reviewed advisory GHSA-83fc-fqcc-2hmg lists affected ranges: npm react-server-dom-parcel >=19.0.0 =19.1.0-canary-7130d0c6-20241212 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 =19.0.0 =19.2.0-canary-63779030-20250328 =19.2.0-canary-63779030-20250328 =19.1.0-canary-7130d0c6-20241212 =19.0.0 <19.0.4)

Commands are suggestions: review each one before running it.

Loading voting…