ChatterBot Vulnerable to Denial of Service via Database Connection Pool Exhaustion
CVE-2026-23842GHSA-v4w8-49pv-mf72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chatterbot 1.2.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI chatterbot
- Affected
- <= 1.2.10
- Fixed in
- 1.2.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v4w8-49pv-mf72 lists affected ranges: PyPI chatterbot >=0 <1.2.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v4w8-49pv-mf72 lists affected ranges: PyPI chatterbot >=0 <=1.2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-23842: 0.54% estimated exploitation activity in the next 30 days; percentile 45.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary ChatterBot versions up to 1.2.10 are vulnerable to a denial-of-service condition caused by improper database session and connection pool management. Concurrent invocations of the getresponse() method can exhaust the underlying SQLAlchemy connection pool, resulting in persistent service unavailability and requiring a manual restart to recover. Details ChatterBot relies on SQLAlchemy for database access and uses a connection pool with default limits. The getresponse() method does not enforce concurrency limits, rate limiting, or explicit session lifecycle controls. When multiple threads concurrently invoke getresponse(), database connections are rapidly consumed and not released in a timely manner. This leads to exhaustion of the SQLAlchemy QueuePool, causing subsequent requests to block and eventually fail with a TimeoutError. This issue can be triggered without authentication in deployments where ChatterBot is exposed as a chatbot service, making it exploitable by remote…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v4w8-49pv-mf72
- Revision 1 · created ·
Published from osv record GHSA-v4w8-49pv-mf72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23842 Advisory: ChatterBot Vulnerable to Denial of Service via Database Connection Pool Exhaustion IDs: CVE-2026-23842, GHSA-v4w8-49pv-mf72 Record: https://patchnext.com/advisories/cve-2026-23842 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chatterbot 1.2.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI chatterbot: affected <= 1.2.10; fixed in 1.2.11 ## Suggested inspection (read-only) - `python -m pip show chatterbot`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chatterbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v4w8-49pv-mf72 (OSV record GHSA-v4w8-49pv-mf72 lists affected ranges: PyPI chatterbot >=0 <1.2.11 (fixed)) - Verified: https://github.com/advisories/GHSA-v4w8-49pv-mf72 (GitHub-reviewed advisory GHSA-v4w8-49pv-mf72 lists affected ranges: PyPI chatterbot >=0 <=1.2.10) Commands are suggestions: review each one before running it.
Loading voting…