Skip to content

← Actionable
Medium, CVSS 5.7amended

LobeHub Vulnerable to Improper Authorization in Presigned Upload

CVE-2026-23835GHSA-wrrr-8jcv-wjf5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/chat 1.143.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-23835: 0.37% estimated exploitation activity in the next 30 days; percentile 30.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The file upload feature in Knowledge Base File Upload does not validate the integrity of the upload request, allowing users to intercept and modify the request parameters. As a result, it is possible to create arbitrary files in abnormal or unintended paths. In addition, since lobechat.com relies on the size parameter from the request to calculate file usage, an attacker can manipulate this value to misrepresent the actual file size, such as uploading a 1 GB file while reporting it as 10 MB, or falsely declaring a 10 MB file as a 1 GB file. Details After entering the Knowledge Base, click the file upload option and upload any file. At this point, use a tool such as Burp Suite to intercept and inspect the request sent to POST /trpc/lambda/file.createFile?batch=1 (the request packet is shown in the image below). By modifying the name and size fields in this request, it is possible to bypass the maximum upload size enforced by LobeChat’s monthly subscription plan and upload…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wrrr-8jcv-wjf5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wrrr-8jcv-wjf5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23835

Advisory: LobeHub Vulnerable to Improper Authorization in Presigned Upload
IDs: CVE-2026-23835, GHSA-wrrr-8jcv-wjf5
Record: https://patchnext.com/advisories/cve-2026-23835 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @lobehub/chat 1.143.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @lobehub/chat: affected < 1.143.3; fixed in 1.143.3

## Suggested inspection (read-only)
- `npm ls @lobehub/chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @lobehub/chat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wrrr-8jcv-wjf5 (OSV record GHSA-wrrr-8jcv-wjf5 lists affected ranges: npm @lobehub/chat >=0 <1.143.3 (fixed))
- Verified: https://github.com/advisories/GHSA-wrrr-8jcv-wjf5 (GitHub-reviewed advisory GHSA-wrrr-8jcv-wjf5 lists affected ranges: npm @lobehub/chat >=0 <1.143.3)

Commands are suggestions: review each one before running it.

Loading voting…