Skip to content

← Actionable
Medium, CVSS 6.8amended

ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component

CVE-2026-23833GHSA-4h3h-63v6-88qx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (esphome 2025.12.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI esphome

    Affected
    >= 2025.9.0, < 2025.12.7
    Fixed in
    2025.12.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-23833: 0.30% estimated exploitation activity in the next 30 days; percentile 22.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An integer overflow in the API component's protobuf decoder allows denial-of-service attacks when API encryption is not used. Details The bounds check ptr + fieldlength end in components/api/proto.cpp can overflow when a malicious client sends a large fieldlength value. This affects all ESPHome device platforms (ESP32, ESP8266, RP2040, LibreTiny). The overflow bypasses the out-of-bounds check, causing the device to read invalid memory and crash. When using the plaintext API protocol, this attack can be performed without authentication. When noise encryption is enabled, knowledge of the encryption key is required. Affected Versions ESPHome 2025.9.0 through 2025.12.6 Mitigation - Upgrade to ESPHome 2025.12.7 or later (or 2026.1.0b3 or later) - Enable API encryption with a unique key per device - Follow the Security Best Practices Severity Low - Users following Security Best Practices with API encryption enabled are not affected without knowledge of the encryption key. Impact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4h3h-63v6-88qx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4h3h-63v6-88qx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23833

Advisory: ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component
IDs: CVE-2026-23833, GHSA-4h3h-63v6-88qx
Record: https://patchnext.com/advisories/cve-2026-23833 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: esphome 2025.12.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI esphome: affected >= 2025.9.0, < 2025.12.7; fixed in 2025.12.7

## Suggested inspection (read-only)
- `python -m pip show esphome`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on esphome.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4h3h-63v6-88qx (OSV record GHSA-4h3h-63v6-88qx lists affected ranges: PyPI esphome >=2025.9.0 <2025.12.7 (fixed))
- Verified: https://github.com/advisories/GHSA-4h3h-63v6-88qx (GitHub-reviewed advisory GHSA-4h3h-63v6-88qx lists affected ranges: PyPI esphome >=2025.9.0 <2025.12.7)

Commands are suggestions: review each one before running it.

Loading voting…