Apache Syncope: Reflected XSS on Enduser Login
CVE-2026-23794GHSA-v84m-gfw5-hm2w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui 4.0.4, 3.0.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui
- Affected
- >= 3.0.0, < 3.0.16>= 4.0.0, < 4.0.4
- Fixed in
- 3.0.16, 4.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v84m-gfw5-hm2w lists affected ranges: Maven org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui >=3.0.0 =4.0.0 <4.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-23794: 0.52% estimated exploitation activity in the next 30 days; percentile 44.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v84m-gfw5-hm2w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23794 Advisory: Apache Syncope: Reflected XSS on Enduser Login IDs: CVE-2026-23794, GHSA-v84m-gfw5-hm2w Record: https://patchnext.com/advisories/cve-2026-23794 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui 4.0.4, 3.0.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui: affected >= 3.0.0, < 3.0.16; >= 4.0.0, < 4.0.4; fixed in 3.0.16, 4.0.4 ## Suggested inspection (read-only) - Maven org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v84m-gfw5-hm2w (GitHub-reviewed advisory GHSA-v84m-gfw5-hm2w lists affected ranges: Maven org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui >=3.0.0 =4.0.0 <4.0.4) Commands are suggestions: review each one before running it.
Loading voting…