Skip to content

← Actionable
Critical, CVSS 9.8amended

REC in MCPJam inspector due to HTTP Endpoint exposes

CVE-2026-23744GHSA-232v-j27c-5pp6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@mcpjam/inspector 1.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-23744: 67.52% estimated exploitation activity in the next 30 days; percentile 99.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MCPJam inspector is the local-first development platform for MCP servers. The Latest version Versions 1.4.2 and earlier are vulnerable to remote code execution (RCE) vulnerability, which allows an attacker to send a crafted HTTP request that triggers the installation of an MCP server, leading to RCE. This vulnerability is similar to CVE-2025-49596, but more severe. While CVE-2025-49596 requires tricking a user into clicking a malicious link, this vulnerability is exploitable with no user interaction. Since MCPJam inspector by default listens on 0.0.0.0 instead of 127.0.0.1, an attacker can trigger the RCE remotely via a simple HTTP request. Details MCPJam inspector binds to 0.0.0.0 making its HTTP APIs remotely reachable. The /api/mcp/connect API, which is intended for connecting to MCP servers, becomes an open entry point for unauthorized requests. When an HTTP request reaches the /connect route, the system extracts the command and args fields without performing any security…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-232v-j27c-5pp6

  2. Revision 2 · amended ·

    Amended from osv record GHSA-232v-j27c-5pp6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-232v-j27c-5pp6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23744

Advisory: REC in MCPJam inspector due to HTTP Endpoint exposes
IDs: CVE-2026-23744, GHSA-232v-j27c-5pp6
Record: https://patchnext.com/advisories/cve-2026-23744 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @mcpjam/inspector 1.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @mcpjam/inspector: affected <= 1.4.2; fixed in 1.4.3

## Suggested inspection (read-only)
- `npm ls @mcpjam/inspector --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @mcpjam/inspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-232v-j27c-5pp6 (GitHub-reviewed advisory GHSA-232v-j27c-5pp6 lists affected ranges: npm @mcpjam/inspector >=0 <=1.4.2)
- Verified: https://osv.dev/vulnerability/GHSA-232v-j27c-5pp6 (OSV record GHSA-232v-j27c-5pp6 lists affected ranges: npm @mcpjam/inspector >=0 <1.4.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…