seroval Affected by Remote Code Execution via JSON Deserialization
CVE-2026-23737GHSA-3rxj-6cgf-8cfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (seroval 1.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm seroval
- Affected
- < 1.4.1
- Fixed in
- 1.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3rxj-6cgf-8cfw lists affected ranges: npm seroval >=0 <1.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3rxj-6cgf-8cfw lists affected ranges: npm seroval >=0 <1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-23737: 0.58% estimated exploitation activity in the next 30 days; percentile 47.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper input handling in the JSON deserialization component can lead to arbitrary JavaScript code execution. The vulnerability can be exploited via overriding constant value and error deserialization, which allows indirect access to unsafe JS evaluation. This requires at least the ability to perform 4 separate requests on the same function and partial knowledge of how the serialized data is used during later runtime processing. This vulnerability affects the fromJSON and fromCrossJSON functions in a client-to-server transmission scenario. No known workarounds or mitigations are known, so please upgrade to the patched version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3rxj-6cgf-8cfw
- Revision 1 · created ·
Published from osv record GHSA-3rxj-6cgf-8cfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23737 Advisory: seroval Affected by Remote Code Execution via JSON Deserialization IDs: CVE-2026-23737, GHSA-3rxj-6cgf-8cfw Record: https://patchnext.com/advisories/cve-2026-23737 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: seroval 1.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm seroval: affected < 1.4.1; fixed in 1.4.1 ## Suggested inspection (read-only) - `npm ls seroval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on seroval. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3rxj-6cgf-8cfw (OSV record GHSA-3rxj-6cgf-8cfw lists affected ranges: npm seroval >=0 <1.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3rxj-6cgf-8cfw (GitHub-reviewed advisory GHSA-3rxj-6cgf-8cfw lists affected ranges: npm seroval >=0 <1.4.1) Commands are suggestions: review each one before running it.
Loading voting…