GraphQL Modules has a Race Condition issue
CVE-2026-23735GHSA-53wg-r69p-v3r7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql-modules 3.1.1, 2.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm graphql-modules
- Affected
- >= 2.2.1, < 2.4.1>= 3.0.0, < 3.1.1
- Fixed in
- 2.4.1, 3.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-53wg-r69p-v3r7 lists affected ranges: npm graphql-modules >=2.2.1 =3.0.0 <3.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-53wg-r69p-v3r7 lists affected ranges: npm graphql-modules >=2.2.1 =3.0.0 <3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-23735: 0.56% estimated exploitation activity in the next 30 days; percentile 46.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Originally reported as an issue #2613 but should be elevated to a security issue as the ExecutionContext is often used to pass authentication tokens from incoming requests to services loading data from backend APIs. Details When 2 or more parallel requests are made which trigger the same service, the context of the requests is mixed up in the service when the context is injected via @ExecutionContext() PoC In a new project/folder, create and install the following package.json: with: configure babel.config.json using: then write the following test GHSA-53wg-r69p-v3r7.spec.ts: and execute using: Your project tree should look like this: Expected vs. Actual Outcome Impact Any application that uses services that inject the context using @ExecutionContext() from a singleton provider are at risk. The more traffic an application has, the higher the chance for parallel requests, the higher the risk.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-53wg-r69p-v3r7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-53wg-r69p-v3r7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23735 Advisory: GraphQL Modules has a Race Condition issue IDs: CVE-2026-23735, GHSA-53wg-r69p-v3r7 Record: https://patchnext.com/advisories/cve-2026-23735 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphql-modules 3.1.1, 2.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm graphql-modules: affected >= 2.2.1, < 2.4.1; >= 3.0.0, < 3.1.1; fixed in 2.4.1, 3.1.1 ## Suggested inspection (read-only) - `npm ls graphql-modules --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphql-modules. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-53wg-r69p-v3r7 (OSV record GHSA-53wg-r69p-v3r7 lists affected ranges: npm graphql-modules >=2.2.1 =3.0.0 <3.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-53wg-r69p-v3r7 (GitHub-reviewed advisory GHSA-53wg-r69p-v3r7 lists affected ranges: npm graphql-modules >=2.2.1 =3.0.0 <3.1.1) Commands are suggestions: review each one before running it.
Loading voting…