XWiki Platform has path traversal via resources parameter in ssx and jsx endpoints when using leading slash
CVE-2026-23734GHSA-xq3r-2qv5-vqqm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.commons:xwiki-commons-classloader-api 18.1.0-rc-1, 17.10.3, 17.4.9, 16.10.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.commons:xwiki-commons-classloader-api
- Affected
- >= 4.2-milestone-2, < 16.10.17>= 17.0.0-rc-1, < 17.4.9>= 17.5.0, < 17.10.3>= 18.0.0-rc-1, < 18.1.0-rc-1
- Fixed in
- 16.10.17, 17.4.9, 17.10.3, 18.1.0-rc-1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xq3r-2qv5-vqqm lists affected ranges: Maven org.xwiki.commons:xwiki-commons-classloader-api >=4.2-milestone-2 =17.0.0-rc-1 =17.5.0 =18.0.0-rc-1 <18.1.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-23734: 18.53% estimated exploitation activity in the next 30 days; percentile 97.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It's possible to get access and read configuration files by using URLs such as http://localhost:8080/bin/ssx/Main/WebHome?resource=/../../WEB-INF/xwiki.cfg&minify=false. This can apparently be reproduced on Tomcat instances. Patches This has been patched in 18.0.0-rc-1, 17.10.3, 17.4.9, 16.10.17. Workarounds There is no known workaround, other than upgrading XWiki. References https://jira.xwiki.org/browse/XCOMMONS-3547 https://github.com/xwiki/xwiki-commons/commit/a979cafd89f6a9c9c0b9ab19744d672df64429bf For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List Attribution The vulnerability was reported by Michał Kołek.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xq3r-2qv5-vqqm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23734 Advisory: XWiki Platform has path traversal via resources parameter in ssx and jsx endpoints when using leading slash IDs: CVE-2026-23734, GHSA-xq3r-2qv5-vqqm Record: https://patchnext.com/advisories/cve-2026-23734 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.commons:xwiki-commons-classloader-api 18.1.0-rc-1, 17.10.3, 17.4.9, 16.10.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.commons:xwiki-commons-classloader-api: affected >= 4.2-milestone-2, < 16.10.17; >= 17.0.0-rc-1, < 17.4.9; >= 17.5.0, < 17.10.3; >= 18.0.0-rc-1, < 18.1.0-rc-1; fixed in 16.10.17, 17.4.9, 17.10.3, 18.1.0-rc-1 ## Suggested inspection (read-only) - Maven org.xwiki.commons:xwiki-commons-classloader-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.commons:xwiki-commons-classloader-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xq3r-2qv5-vqqm (GitHub-reviewed advisory GHSA-xq3r-2qv5-vqqm lists affected ranges: Maven org.xwiki.commons:xwiki-commons-classloader-api >=4.2-milestone-2 =17.0.0-rc-1 =17.5.0 =18.0.0-rc-1 <18.1.0-rc-1) Commands are suggestions: review each one before running it.
Loading voting…