Skip to content

← Actionable
Medium, CVSS 5.4

CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

CVE-2026-23643GHSA-qh8m-9qxx-53m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 5.3.1, 5.2.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/cakephp

    Affected
    >= 5.2.10, < 5.2.12>= 5.3.0, <= 5.3.0
    Fixed in
    5.3.1, 5.2.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-23643: 0.28% estimated exploitation activity in the next 30 days; percentile 20.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. Patches This issue has been fixed in 5.2.12 and 5.3.1 Workarounds If you are unable to upgrade, you should avoid using Paginator::limitControl() until you can upgrade.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qh8m-9qxx-53m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23643

Advisory: CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
IDs: CVE-2026-23643, GHSA-qh8m-9qxx-53m5
Record: https://patchnext.com/advisories/cve-2026-23643 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 5.3.1, 5.2.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/cakephp: affected >= 5.2.10, < 5.2.12; >= 5.3.0, <= 5.3.0; fixed in 5.3.1, 5.2.12

## Suggested inspection (read-only)
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qh8m-9qxx-53m5 (GitHub-reviewed advisory GHSA-qh8m-9qxx-53m5 lists affected ranges: Packagist cakephp/cakephp >=5.2.10 =5.3.0 <=5.3.0)

Commands are suggestions: review each one before running it.

Loading voting…