Pepr Has Overly Permissive RBAC ClusterRole in Admin Mode
CVE-2026-23634GHSA-w54x-r83c-x79q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pepr 1.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pepr
- Affected
- < 1.0.5
- Fixed in
- 1.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w54x-r83c-x79q lists affected ranges: npm pepr >=0 <1.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w54x-r83c-x79q lists affected ranges: npm pepr >=0 <1.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.7 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-23634: 0.25% estimated exploitation activity in the next 30 days; percentile 16.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Severity: LOW Target: /workspace/pepr/src/lib/assets/rbac.ts Endpoint: Kubernetes RBAC configuration Method: Deployment Response / Rationale Pepr defaults to rbacMode: "admin" because the initial experience is designed to be frictionless for new users. This mode ensures that users can deploy and run the default hello-pepr.ts module without needing to understand or pre-configure RBAC rules. It’s important to note that hello-pepr.ts is intended strictly as a demo to showcase Pepr features and workflow. It is not intended for production use, and the documentation explicitly calls out that admin RBAC should not be used in production environments. That said, if a user skips the documentation and does not review the npx pepr build options, they could deploy a module with broader privileges than necessary. We consider this low severity because Pepr is a framework: the module author is ultimately responsible for selecting the appropriate RBAC scope for their module and environment as each…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w54x-r83c-x79q
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w54x-r83c-x79q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23634 Advisory: Pepr Has Overly Permissive RBAC ClusterRole in Admin Mode IDs: CVE-2026-23634, GHSA-w54x-r83c-x79q Record: https://patchnext.com/advisories/cve-2026-23634 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pepr 1.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pepr: affected < 1.0.5; fixed in 1.0.5 ## Suggested inspection (read-only) - `npm ls pepr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pepr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w54x-r83c-x79q (OSV record GHSA-w54x-r83c-x79q lists affected ranges: npm pepr >=0 <1.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-w54x-r83c-x79q (GitHub-reviewed advisory GHSA-w54x-r83c-x79q lists affected ranges: npm pepr >=0 <1.0.5) Commands are suggestions: review each one before running it.
Loading voting…