Kimai has an Authenticated Server-Side Template Injection (SSTI)
CVE-2026-23626GHSA-jg2j-2w24-54cg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.46.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist kimai/kimai
- Affected
- < 2.46.0
- Fixed in
- 2.46.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jg2j-2w24-54cg lists affected ranges: Packagist kimai/kimai >=0 <2.46.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-23626: 0.46% estimated exploitation activity in the next 30 days; percentile 40.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Kimai 2.45.0 - Authenticated Server-Side Template Injection (SSTI) Vulnerability Summary | Field | Value | |-------|-------| | Title | Authenticated SSTI via Permissive Export Template Sandbox || Attack Vector | Network | | Attack Complexity | Low | | Privileges Required | High (Admin with export permissions and server access) | | User Interaction | None | | Impact | Confidentiality: HIGH (Credential/Secret Extraction) | | Affected Versions | Kimai 2.45.0 (likely earlier versions) | | Tested On | Docker: kimai/kimai2:apache-2.45.0 | | Discovery Date | 2026-01-05 | --- Why Scope is "Changed": The extracted APPSECRET can be used to forge Symfony login links for ANY user account, expanding the attack beyond the initially compromised admin context. --- Vulnerability Description Kimai's export functionality uses a Twig sandbox with an overly permissive security policy (DefaultPolicy) that allows arbitrary method calls on objects available in the template context. An authenticated user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jg2j-2w24-54cg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23626 Advisory: Kimai has an Authenticated Server-Side Template Injection (SSTI) IDs: CVE-2026-23626, GHSA-jg2j-2w24-54cg Record: https://patchnext.com/advisories/cve-2026-23626 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.46.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist kimai/kimai: affected < 2.46.0; fixed in 2.46.0 ## Suggested inspection (read-only) - Packagist kimai/kimai: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kimai/kimai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jg2j-2w24-54cg (GitHub-reviewed advisory GHSA-jg2j-2w24-54cg lists affected ranges: Packagist kimai/kimai >=0 <2.46.0) Commands are suggestions: review each one before running it.
Loading voting…