Apache Camel: KeycloakSecurityPolicy does not validate issuer of JWT tokens against configured realm
CVE-2026-23552GHSA-c3f3-cc42-xr9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-keycloak 4.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-keycloak
- Affected
- >= 4.15.0, < 4.18.0
- Fixed in
- 4.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3f3-cc42-xr9v lists affected ranges: Maven org.apache.camel:camel-keycloak >=4.15.0 <4.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-23552: 0.61% estimated exploitation activity in the next 30 days; percentile 49.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-Realm Token Acceptance Bypass in KeycloakSecurityPolicy Apache Camel Keycloak component. The Camel-Keycloak KeycloakSecurityPolicy does not validate the iss (issuer) claim of JWT tokens against the configured realm. A token issued by one Keycloak realm is silently accepted by a policy configured for a completely different realm, breaking tenant isolation. This issue affects Apache Camel: from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c3f3-cc42-xr9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23552 Advisory: Apache Camel: KeycloakSecurityPolicy does not validate issuer of JWT tokens against configured realm IDs: CVE-2026-23552, GHSA-c3f3-cc42-xr9v Record: https://patchnext.com/advisories/cve-2026-23552 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-keycloak 4.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-keycloak: affected >= 4.15.0, < 4.18.0; fixed in 4.18.0 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-keycloak: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-keycloak. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c3f3-cc42-xr9v (GitHub-reviewed advisory GHSA-c3f3-cc42-xr9v lists affected ranges: Maven org.apache.camel:camel-keycloak >=4.15.0 <4.18.0) Commands are suggestions: review each one before running it.
Loading voting…