Dask Distributed is Vulnerable to Remote Code Execution via Jupyter Proxy and Dashboard
CVE-2026-23528GHSA-c336-7962-wfj2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (distributed 2026.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI distributed
- Affected
- < 2026.1.0
- Fixed in
- 2026.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c336-7962-wfj2 lists affected ranges: PyPI distributed >=0 <2026.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c336-7962-wfj2 lists affected ranges: PyPI distributed >=0 <2026.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-23528: 0.23% estimated exploitation activity in the next 30 days; percentile 14.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When Jupyter Lab, jupyter-server-proxy and Dask distributed are all run together it is possible to craft a URL which will result in code being executed by Jupyter due to a cross-side-scripting (XSS) bug in the Dask dashboard. It is possible for attackers to craft a phishing URL that assumes Jupyter Lab and Dask may be running on localhost and using default ports. If a user clicks on the malicious link it will open an error page in the Dask Dashboard via the Jupyter Lab proxy which will cause code to be executed by the default Jupyter Python kernel. In order for a user to be impacted they must be running Jupyter Lab locally on the default port (with the jupyter-server-proxy) and a Dask distributed cluster on the default port. Then they would need to click the link which would execute the malicious code. Patches This has been fixed in the 2026.1.0 release. All users should upgrade to this version. Mitigations There are no known workarounds for this bug. The only complete…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c336-7962-wfj2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c336-7962-wfj2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23528 Advisory: Dask Distributed is Vulnerable to Remote Code Execution via Jupyter Proxy and Dashboard IDs: CVE-2026-23528, GHSA-c336-7962-wfj2 Record: https://patchnext.com/advisories/cve-2026-23528 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: distributed 2026.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI distributed: affected < 2026.1.0; fixed in 2026.1.0 ## Suggested inspection (read-only) - `python -m pip show distributed`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on distributed. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c336-7962-wfj2 (OSV record GHSA-c336-7962-wfj2 lists affected ranges: PyPI distributed >=0 <2026.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-c336-7962-wfj2 (GitHub-reviewed advisory GHSA-c336-7962-wfj2 lists affected ranges: PyPI distributed >=0 <2026.1.0) Commands are suggestions: review each one before running it.
Loading voting…