Laravel Redis Horizontal Scaling Insecure Deserialization
CVE-2026-23524GHSA-m27r-m6rx-mhm4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/reverb 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/reverb
- Affected
- < 1.7.0
- Fixed in
- 1.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m27r-m6rx-mhm4 lists affected ranges: Packagist laravel/reverb >=0 <1.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-23524: 0.98% estimated exploitation activity in the next 30 days; percentile 62.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability affects Laravel Reverb versions prior to v1.7.0 when horizontal scaling is enabled (REVERBSCALINGENABLED=true). The exploitability of this vulnerability is increased because Redis servers are commonly deployed without authentication. With horizontal scaling enabled, Reverb servers communicate via Redis PubSub. Reverb previously passed data from the Redis channel directly into PHP’s unserialize() function without restricting which classes could be instantiated. Risk: Remote Code Execution (RCE) Patches This vulnerability is fixed in Laravel Reverb v1.7.0. Update your dependency to laravel/reverb: ^1.7.0 immediately. Workarounds If you cannot upgrade to v1.7.0, you should apply the following mitigations: Redis Security: Require a strong password for Redis access and ensure the service is only accessible via a private network or local loopback. Disable Scaling: If your environment uses only one Reverb node, set REVERBSCALINGENABLED=false to bypass the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m27r-m6rx-mhm4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23524 Advisory: Laravel Redis Horizontal Scaling Insecure Deserialization IDs: CVE-2026-23524, GHSA-m27r-m6rx-mhm4 Record: https://patchnext.com/advisories/cve-2026-23524 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laravel/reverb 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/reverb: affected < 1.7.0; fixed in 1.7.0 ## Suggested inspection (read-only) - Packagist laravel/reverb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/reverb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m27r-m6rx-mhm4 (GitHub-reviewed advisory GHSA-m27r-m6rx-mhm4 lists affected ranges: Packagist laravel/reverb >=0 <1.7.0) Commands are suggestions: review each one before running it.
Loading voting…