Skip to content

← Actionable
High, CVSS 7.1

Fleet has an Access Control vulnerability in debug/pprof endpoints

CVE-2026-23517GHSA-4r5r-ccr6-q6f6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 4.78.3-0.20260112221730-5c030e32a3a9; github.com/fleetdm/fleet 4.78.3, 4.77.1, 4.76.2, 4.75.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/fleetdm/fleet/v4

    Affected
    < 4.78.3-0.20260112221730-5c030e32a3a9
    Fixed in
    4.78.3-0.20260112221730-5c030e32a3a9
  • Go github.com/fleetdm/fleet

    Affected
    >= 4.78.0, < 4.78.3>= 4.77.0, < 4.77.1>= 4.76.0, < 4.76.2>= 4.75.0, < 4.75.2
    Fixed in
    4.75.2, 4.78.3, 4.77.1, 4.76.2

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4r5r-ccr6-q6f6 lists affected ranges: Go github.com/fleetdm/fleet >=4.78.0 =4.77.0 =4.76.0 =4.75.0 =0 <4.78.3-0.20260112221730-5c030e32a3a9

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-23517: 0.29% estimated exploitation activity in the next 30 days; percentile 21.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A broken access control issue in Fleet allowed authenticated users to access debug and profiling endpoints regardless of role. As a result, low-privilege users could view internal server diagnostics and trigger resource-intensive profiling operations. Impact Fleet’s debug/pprof endpoints are accessible to any authenticated user regardless of role, including the lowest-privilege “Observer” role. This allows low-privilege users to access sensitive server internals, including runtime profiling data and in-memory application state, and to trigger CPU-intensive profiling operations that could lead to denial of service. Patches - 4.78.3 - 4.77.1 - 4.76.2 - 4.75.2 - 4.53.3 Workarounds If an immediate upgrade is not possible, users should put the debug/pprof endpoints behind an IP allowlist. For more information If you have any questions or comments about this advisory: Email us at security@fleetdm.com Join #fleet in osquery Slack Credits We thank @secfox-ai for responsibly reporting…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4r5r-ccr6-q6f6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23517

Advisory: Fleet has an Access Control vulnerability in debug/pprof endpoints
IDs: CVE-2026-23517, GHSA-4r5r-ccr6-q6f6
Record: https://patchnext.com/advisories/cve-2026-23517 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 4.78.3-0.20260112221730-5c030e32a3a9; github.com/fleetdm/fleet 4.78.3, 4.77.1, 4.76.2, 4.75.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/fleetdm/fleet/v4: affected < 4.78.3-0.20260112221730-5c030e32a3a9; fixed in 4.78.3-0.20260112221730-5c030e32a3a9
- Go github.com/fleetdm/fleet: affected >= 4.78.0, < 4.78.3; >= 4.77.0, < 4.77.1; >= 4.76.0, < 4.76.2; >= 4.75.0, < 4.75.2; fixed in 4.75.2, 4.78.3, 4.77.1, 4.76.2

## Suggested inspection (read-only)
- Go github.com/fleetdm/fleet/v4: check the installed version with your package manager.
- Go github.com/fleetdm/fleet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/fleetdm/fleet/v4, github.com/fleetdm/fleet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4r5r-ccr6-q6f6 (GitHub-reviewed advisory GHSA-4r5r-ccr6-q6f6 lists affected ranges: Go github.com/fleetdm/fleet >=4.78.0 =4.77.0 =4.76.0 =4.75.0 =0 <4.78.3-0.20260112221730-5c030e32a3a9)

Commands are suggestions: review each one before running it.

Loading voting…