Signal K set-system-time plugin vulnerable to RCE - Command Injection
CVE-2026-23515GHSA-p8gp-2w28-mhwg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@signalk/set-system-time 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p8gp-2w28-mhwg lists affected ranges: npm @signalk/set-system-time >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p8gp-2w28-mhwg lists affected ranges: npm @signalk/set-system-time >=0 <1.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-23515: 4.52% estimated exploitation activity in the next 30 days; percentile 91.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Command Injection vulnerability allows authenticated users with write permissions to execute arbitrary shell commands on the Signal K server when the set-system-time plugin is enabled. Unauthenticated users can also exploit this vulnerability if security is disabled on the Signal K server. This occurs due to unsafe construction of shell commands when processing navigation.datetime values received via WebSocket delta messages. Details Product: Signal K set-system-time plugin Repository: https://github.com/SignalK/set-system-time File: index.js, lines 60-71 The vulnerability has three components: 1. Unsanitized Input: The datetime value from navigation.datetime Signal K path is directly interpolated into a shell command without validation 2. Shell Execution: The command is executed via spawn('sh', ['-c', command]), which interprets shell metacharacters 3. Sudo Privileges: The plugin can execute with root privileges if sudo is misconfigured, instructions to limit passwordless…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p8gp-2w28-mhwg
- Revision 2 · amended ·
Amended from osv record GHSA-p8gp-2w28-mhwg
- Revision 1 · created ·
Published from ghsa record GHSA-p8gp-2w28-mhwg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23515 Advisory: Signal K set-system-time plugin vulnerable to RCE - Command Injection IDs: CVE-2026-23515, GHSA-p8gp-2w28-mhwg Record: https://patchnext.com/advisories/cve-2026-23515 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @signalk/set-system-time 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @signalk/set-system-time: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - `npm ls @signalk/set-system-time --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @signalk/set-system-time. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p8gp-2w28-mhwg (GitHub-reviewed advisory GHSA-p8gp-2w28-mhwg lists affected ranges: npm @signalk/set-system-time >=0 <1.5.0) - Verified: https://osv.dev/vulnerability/GHSA-p8gp-2w28-mhwg (OSV record GHSA-p8gp-2w28-mhwg lists affected ranges: npm @signalk/set-system-time >=0 <1.5.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…