Skip to content

← Actionable
Medium, CVSS 4.3

Pimcore's Admin Classic Bundle is Missing Function Level Authorization on "Predefined Properties" Listing

CVE-2026-23495GHSA-hqrp-m84v-2m2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/admin-ui-classic-bundle 2.2.3, 1.7.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-23495: 0.36% estimated exploitation activity in the next 30 days; percentile 29.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The API endpoint for listing Predefined Properties in the Pimcore platform lacks adequate server-side authorization checks. Predefined Properties are configurable metadata definitions (e.g., name, key, type, default value) used across documents, assets, and objects to standardize custom attributes and improve editorial workflows, as documented in Pimcore's official properties guide. Testing confirmed that an authenticated backend user without explicit permissions for property management could successfully call the endpoint and retrieve the complete list of these configurations. This exemplifies Broken Access Control (OWASP Top 10 A01:2021), enabling unauthorized access to administrative features and potentially violating role-based access controls inherent to Pimcore's multi-user environment. Details The backend user without permission was still able to list "Predefined Properties" item Step to Reproduce the issue login as Admin (full permission) and clicked "Predefined…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hqrp-m84v-2m2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23495

Advisory: Pimcore's Admin Classic Bundle is Missing Function Level Authorization on "Predefined Properties" Listing
IDs: CVE-2026-23495, GHSA-hqrp-m84v-2m2f
Record: https://patchnext.com/advisories/cve-2026-23495 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/admin-ui-classic-bundle 2.2.3, 1.7.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/admin-ui-classic-bundle: affected >= 2.0.0-RC1, <= 2.2.2; <= 1.7.15; fixed in 2.2.3, 1.7.16

## Suggested inspection (read-only)
- Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/admin-ui-classic-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hqrp-m84v-2m2f (GitHub-reviewed advisory GHSA-hqrp-m84v-2m2f lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=2.0.0-RC1 =0 <=1.7.15)

Commands are suggestions: review each one before running it.

Loading voting…