Skip to content

← Actionable
Medium, CVSS 4.3

Pimcore is Vulnerable to Broken Access Control: Missing Function Level Authorization on "Static Routes" Listing

CVE-2026-23494GHSA-m3r2-724c-pwgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 12.3.1, 11.5.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist pimcore/pimcore

    Affected
    >= 12.0.0-RC1, <= 12.3<= 11.5.13
    Fixed in
    12.3.1, 11.5.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-23494: 0.35% estimated exploitation activity in the next 30 days; percentile 28.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The application fails to enforce proper server-side authorization checks on the API endpoint responsible for reading or listing static routes. In Pimcore, static routes are custom URL patterns defined via the backend interface or the var/config/staticroutes.php file, including details like regex-based patterns, controllers, variables, and priorities. These routes are registered automatically through the PimcoreStaticRoutesBundle and integrated into the MVC routing system. Testing revealed that an authenticated backend user lacking explicit permissions was able to invoke the endpoint (e.g., GET /api/static-routes) and retrieve sensitive route configurations. This violates OWASP A01:2021 Broken Access Control, as function-level authorization is absent, allowing unauthorized access to internal routing metadata. Without validation, the endpoint exposes route structures, potentially revealing application architecture, endpoints, or custom logic intended for administrative roles…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m3r2-724c-pwgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23494

Advisory: Pimcore is Vulnerable to Broken Access Control: Missing Function Level Authorization on "Static Routes" Listing
IDs: CVE-2026-23494, GHSA-m3r2-724c-pwgf
Record: https://patchnext.com/advisories/cve-2026-23494 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 12.3.1, 11.5.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected >= 12.0.0-RC1, <= 12.3; <= 11.5.13; fixed in 12.3.1, 11.5.14

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m3r2-724c-pwgf (GitHub-reviewed advisory GHSA-m3r2-724c-pwgf lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 <=11.5.13)

Commands are suggestions: review each one before running it.

Loading voting…