Pimcore ENV Variables and Cookie Informations are exposed in http_error_log
CVE-2026-23493GHSA-q433-j342-rp9h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 12.3.1, 11.5.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- >= 12.0.0-RC1, <= 12.3<= 11.5.13
- Fixed in
- 12.3.1, 11.5.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q433-j342-rp9h lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 <=11.5.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2026-23493: 0.43% estimated exploitation activity in the next 30 days; percentile 36.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The httperrorlog file stores the $COOKIE and $SERVER variables, which means sensitive information such as database passwords, cookie session data, and other details can be accessed or recovered through the Pimcore backend. Details It’s better to remove both lines, as this information makes little sense in this context anyway. https://github.com/pimcore/pimcore/blob/12.x/bundles/SeoBundle/src/EventListener/ResponseExceptionListener.php#L92 https://github.com/pimcore/pimcore/blob/12.x/bundles/SeoBundle/src/EventListener/ResponseExceptionListener.php#L93 PoC In the Pimcore backend, navigate to "Search Engine Optimization" and click on "HTTP Errors." Double-click on an entry to view its details. Here, you may find sensitive data exposed. Impact Pimcore backend users can access sensitive environment variables, potentially exposing critical information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q433-j342-rp9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23493 Advisory: Pimcore ENV Variables and Cookie Informations are exposed in http_error_log IDs: CVE-2026-23493, GHSA-q433-j342-rp9h Record: https://patchnext.com/advisories/cve-2026-23493 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 12.3.1, 11.5.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected >= 12.0.0-RC1, <= 12.3; <= 11.5.13; fixed in 12.3.1, 11.5.14 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q433-j342-rp9h (GitHub-reviewed advisory GHSA-q433-j342-rp9h lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 <=11.5.13) Commands are suggestions: review each one before running it.
Loading voting…