Skip to content

← Actionable
High, CVSS 8.8

Pimcore Has an Incomplete Patch for CVE-2023-30848

CVE-2026-23492GHSA-qvr7-7g55-69xj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 12.3.1, 11.5.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist pimcore/pimcore

    Affected
    >= 12.0.0-RC1, < 12.3.1<= 11.5.13
    Fixed in
    12.3.1, 11.5.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-23492: 0.47% estimated exploitation activity in the next 30 days; percentile 40.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An incomplete SQL injection patch in the Admin Search Find API allows an authenticated attacker to perform blind SQL injection. Although CVE-2023-30848 attempted to mitigate SQL injection by removing SQL comments (--) and catching syntax errors, the fix is insufficient. Attackers can still inject SQL payloads that do not rely on comments and infer database information via blind techniques. This vulnerability affects the admin interface and can lead to database information disclosure. Details The vulnerability exists in the Admin Search Find API endpoint: In CVE-2023-30848, the following patch was applied: - SQL comments are removed by replacing -- - SQL syntax errors are caught and replaced with a generic exception Relevant commit: https://github.com/pimcore/pimcore/commit/25ad8674886f2b938243cbe13e33e204a2e35cc3 Key changes include: However, this mitigation is incomplete for the following reasons: 1. Only -- is filtered SQL injection does not require SQL comments. Payloads…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qvr7-7g55-69xj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-23492

Advisory: Pimcore Has an Incomplete Patch for CVE-2023-30848
IDs: CVE-2026-23492, GHSA-qvr7-7g55-69xj
Record: https://patchnext.com/advisories/cve-2026-23492 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 12.3.1, 11.5.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected >= 12.0.0-RC1, < 12.3.1; <= 11.5.13; fixed in 12.3.1, 11.5.14

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qvr7-7g55-69xj (GitHub-reviewed advisory GHSA-qvr7-7g55-69xj lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 <=11.5.13)

Commands are suggestions: review each one before running it.

Loading voting…