pyasn1 has a DoS vulnerability in decoder
CVE-2026-23490GHSA-63vm-454h-vhhq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyasn1 0.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyasn1
- Affected
- >= 0.6.1, <= 0.6.1
- Fixed in
- 0.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-63vm-454h-vhhq lists affected ranges: PyPI pyasn1 >=0.6.1 <0.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-63vm-454h-vhhq lists affected ranges: PyPI pyasn1 >=0.6.1 <=0.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-23490: 0.76% estimated exploitation activity in the next 30 days; percentile 55.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary After reviewing pyasn1 v0.6.1 a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. Details The integer issue can be found in the decoder as reloid += ((subId << 7) + nextSubId,): https://github.com/pyasn1/pyasn1/blob/main/pyasn1/codec/ber/decoder.py#L496 PoC For the DoS: Screenshots with the results: DoS <img width="944" height="207" alt="Screenshot20251219160840" src="https://github.com/user-attachments/assets/68b9566b-5ee1-47b0-a269-605b037dfc4f" / <img width="931" height="231" alt="Screenshot20251219152815" src="https://github.com/user-attachments/assets/62eacf4f-eb31-4fba-b7a8-e8151484a9fa" / Leak analysis A potential heap leak was investigated but came back clean: Scenario 1. An attacker creates a malicious X.509 certificate. 2. The application validates certificates. 3. The application accepts the malicious certificate and tries decoding resulting in the issues mentioned above. Impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-63vm-454h-vhhq
- Revision 1 · created ·
Published from osv record GHSA-63vm-454h-vhhq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-23490 Advisory: pyasn1 has a DoS vulnerability in decoder IDs: CVE-2026-23490, GHSA-63vm-454h-vhhq Record: https://patchnext.com/advisories/cve-2026-23490 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyasn1 0.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyasn1: affected >= 0.6.1, <= 0.6.1; fixed in 0.6.2 ## Suggested inspection (read-only) - `python -m pip show pyasn1`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyasn1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-63vm-454h-vhhq (OSV record GHSA-63vm-454h-vhhq lists affected ranges: PyPI pyasn1 >=0.6.1 <0.6.2 (fixed)) - Verified: https://github.com/advisories/GHSA-63vm-454h-vhhq (GitHub-reviewed advisory GHSA-63vm-454h-vhhq lists affected ranges: PyPI pyasn1 >=0.6.1 <=0.6.1) Commands are suggestions: review each one before running it.
Loading voting…