Skip to content

← Actionable
Medium, CVSS 5.5amended

markdown-it is has a Regular Expression Denial of Service (ReDoS)

CVE-2026-2327GHSA-38c4-r59v-3vqw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (markdown-it 14.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm markdown-it

    Affected
    >= 13.0.0, < 14.1.1
    Fixed in
    14.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-2327: 0.74% estimated exploitation activity in the next 30 days; percentile 54.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of the package markdown-it from 13.0.0 and before 14.1.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of the regex /\+$/ in the linkify function. An attacker can supply a long sequence of characters followed by a non-matching character, which triggers excessive backtracking and may lead to a denial-of-service condition.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-38c4-r59v-3vqw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-38c4-r59v-3vqw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-2327

Advisory: markdown-it is has a Regular Expression Denial of Service (ReDoS)
IDs: CVE-2026-2327, GHSA-38c4-r59v-3vqw
Record: https://patchnext.com/advisories/cve-2026-2327 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: markdown-it 14.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm markdown-it: affected >= 13.0.0, < 14.1.1; fixed in 14.1.1

## Suggested inspection (read-only)
- `npm ls markdown-it --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on markdown-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-38c4-r59v-3vqw (OSV record GHSA-38c4-r59v-3vqw lists affected ranges: npm markdown-it >=13.0.0 <14.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-38c4-r59v-3vqw (GitHub-reviewed advisory GHSA-38c4-r59v-3vqw lists affected ranges: npm markdown-it >=13.0.0 <14.1.1)

Commands are suggestions: review each one before running it.

Loading voting…