Mattermost doesn't limit the size of the request body on the start meeting API endpoint
CVE-2026-2325GHSA-m3p3-8frq-q7qh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 11.5.2, 11.4.4, 10.11.14; github.com/mattermost/mattermost-plugin-msteams-meetings 1.1.1-0.20260213105619-c5892dd169de), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server
- Affected
- >= 11.5.0, < 11.5.2>= 10.11.0, < 10.11.14>= 11.4.0, < 11.4.4
- Fixed in
- 11.4.4, 10.11.14, 11.5.2
Go github.com/mattermost/mattermost-plugin-msteams-meetings
- Affected
- < 1.1.1-0.20260213105619-c5892dd169de
- Fixed in
- 1.1.1-0.20260213105619-c5892dd169de
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3p3-8frq-q7qh lists affected ranges: Go github.com/mattermost/mattermost-server >=11.5.0 =10.11.0 =11.4.0 =0 <1.1.1-0.20260213105619-c5892dd169de
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-2325: 0.24% estimated exploitation activity in the next 30 days; percentile 15.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to limit the size of the request body on the start meeting API endpoint, which allows an authenticated attacker to cause resource exhaustion or denial of service via a crafted oversized HTTP POST request to {{/api/v1/meetings}}.. Mattermost Advisory ID: MMSA-2026-00608
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m3p3-8frq-q7qh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-2325 Advisory: Mattermost doesn't limit the size of the request body on the start meeting API endpoint IDs: CVE-2026-2325, GHSA-m3p3-8frq-q7qh Record: https://patchnext.com/advisories/cve-2026-2325 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 11.5.2, 11.4.4, 10.11.14; github.com/mattermost/mattermost-plugin-msteams-meetings 1.1.1-0.20260213105619-c5892dd169de. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-server: affected >= 11.5.0, < 11.5.2; >= 10.11.0, < 10.11.14; >= 11.4.0, < 11.4.4; fixed in 11.4.4, 10.11.14, 11.5.2 - Go github.com/mattermost/mattermost-plugin-msteams-meetings: affected < 1.1.1-0.20260213105619-c5892dd169de; fixed in 1.1.1-0.20260213105619-c5892dd169de ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. - Go github.com/mattermost/mattermost-plugin-msteams-meetings: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-msteams-meetings. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m3p3-8frq-q7qh (GitHub-reviewed advisory GHSA-m3p3-8frq-q7qh lists affected ranges: Go github.com/mattermost/mattermost-server >=11.5.0 =10.11.0 =11.4.0 =0 <1.1.1-0.20260213105619-c5892dd169de) Commands are suggestions: review each one before running it.
Loading voting…