Skip to content

← Actionable
Medium, CVSS 4.3

Mattermost doesn't validate user permissions when creating Jira issues from Mattermost posts

CVE-2026-22892GHSA-9pj7-jh2r-87g8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 11.2.2, 11.1.3, 10.11.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-22892: 0.27% estimated exploitation activity in the next 30 days; percentile 19.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 fail to validate user permissions when creating Jira issues from Mattermost posts, which allows an authenticated attacker with access to the Jira plugin to read post content and attachments from channels they do not have access to via the /create-issue API endpoint by providing the post ID of an inaccessible post.. Mattermost Advisory ID: MMSA-2025-00550

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9pj7-jh2r-87g8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22892

Advisory: Mattermost doesn't validate user permissions when creating Jira issues from Mattermost posts
IDs: CVE-2026-22892, GHSA-9pj7-jh2r-87g8
Record: https://patchnext.com/advisories/cve-2026-22892 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 11.2.2, 11.1.3, 10.11.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost-server: affected >= 11.2.0, <= 11.2.1; >= 11.1.0, <= 11.1.2; >= 10.11.0, <= 10.11.9; fixed in 11.2.2, 11.1.3, 10.11.10

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9pj7-jh2r-87g8 (GitHub-reviewed advisory GHSA-9pj7-jh2r-87g8 lists affected ranges: Go github.com/mattermost/mattermost-server >=11.2.0 =11.1.0 =10.11.0 <=10.11.9)

Commands are suggestions: review each one before running it.

Loading voting…