Skip to content

← Actionable
High, CVSS 8.7amended

GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE

CVE-2026-22871GHSA-xg9w-vg3g-6m68

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guarddog 2.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI guarddog

    Affected
    < 2.7.1
    Fixed in
    2.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-22871: 1.06% estimated exploitation activity in the next 30 days; percentile 64.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability exists in GuardDog's safeextract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. CWE: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory) Details Vulnerable Code File: guarddog/utils/archives.py Root Cause The comment about zip.extract() fooled me at first :) then I noticed the os.path.join() call. The vulnerability stems from incorrect usage of Python's zipfile.ZipFile.extract() API: - The path parameter should be the target directory, not a full file path - extract() automatically appends the member name to the path - By passing os.path.join(targetdirectory, file), GuardDog causes the filename to be appended twice - This breaks zipfile's built-in path traversal sanitization Attack Vector 1. Attacker creates malicious wheel with path traversal filenames 2. Uploads to PyPI…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xg9w-vg3g-6m68

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xg9w-vg3g-6m68

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22871

Advisory: GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE
IDs: CVE-2026-22871, GHSA-xg9w-vg3g-6m68
Record: https://patchnext.com/advisories/cve-2026-22871 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guarddog 2.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI guarddog: affected < 2.7.1; fixed in 2.7.1

## Suggested inspection (read-only)
- `python -m pip show guarddog`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guarddog.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xg9w-vg3g-6m68 (OSV record GHSA-xg9w-vg3g-6m68 lists affected ranges: PyPI guarddog >=0 <2.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xg9w-vg3g-6m68 (GitHub-reviewed advisory GHSA-xg9w-vg3g-6m68 lists affected ranges: PyPI guarddog >=0 <2.7.1)

Commands are suggestions: review each one before running it.

Loading voting…