Skip to content

← Actionable
Medium, CVSS 6.3amended

Outray cli is vulnerable to race conditions in tunnels creation

CVE-2026-22820GHSA-3pqc-836w-jgr7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (outray 0.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm outray

    Affected
    < 0.1.5
    Fixed in
    0.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-22820: 0.20% estimated exploitation activity in the next 30 days; percentile 10.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A TOCTOU race condition vulnerability allows a user to exceed the set number of active tunnels in their subscription plan. Details Affected conponent: apps/web/src/routes/api/tunnel/register.ts - /tunnel/register endpoint code-: - It checks if the tunnel exists in the database. - Limit is checked here-: - Redis is checked for existing tunnel to check for reconnection. - If the tunnel limit is exceeded, it pops up the tunnel limit error. - If the limit is not exceeded, it triggers a the Insert Statement without locking transactions from other request - If parallel requests are made by the wshandler in /outray/outray-main/apps/tunnel/src/core/WSHandler.ts from the command line app. A request can work on a non updated row because the insert row has not been triggered allowing the user to bypass the limit. It is much explained in the proof of concept. The key takeaway is db transactions should remain locked. PoC Using this simple bash script, the outray binary will be run at the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3pqc-836w-jgr7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3pqc-836w-jgr7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22820

Advisory: Outray cli is vulnerable to race conditions in tunnels creation
IDs: CVE-2026-22820, GHSA-3pqc-836w-jgr7
Record: https://patchnext.com/advisories/cve-2026-22820 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: outray 0.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm outray: affected < 0.1.5; fixed in 0.1.5

## Suggested inspection (read-only)
- `npm ls outray --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on outray.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3pqc-836w-jgr7 (OSV record GHSA-3pqc-836w-jgr7 lists affected ranges: npm outray >=0 <0.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-3pqc-836w-jgr7 (GitHub-reviewed advisory GHSA-3pqc-836w-jgr7 lists affected ranges: npm outray >=0 <0.1.5)

Commands are suggestions: review each one before running it.

Loading voting…