Skip to content

← Actionable
Medium, CVSS 5.9amended

Outray has a Race Condition in the cli's webapp

CVE-2026-22819GHSA-45hj-9x76-wp9g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (outray 0.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm outray

    Affected
    < 0.1.5
    Fixed in
    0.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2026-22819: 0.24% estimated exploitation activity in the next 30 days; percentile 15.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This vulnerability allows a user i.e a free plan user to get more than the desired subdomains due to lack of db transaction lock mechanisms in https://github.com/akinloluwami/outray/blob/main/apps/web/src/routes/api/%24orgSlug/subdomains/index.ts Details - The affected code-: - The first part of the code checks the user plan and determine his/her existingdomains without locking the transaction and allowing it to run. - The other part of the code checks if the desired domain is more than the limit. - Finally, it inserts the subdomain also after the whole check without locking transactions. - An attacker can exploit this by making parallel requests to the same endpoint and if the second request reads row subdomains before the INSERT statement of request one is made.It allows the attacker to act on a not yet updated row which bypasses the checks and allow the attacker to get more subdomains.For example-: - The attack focuses on exploiting the race window between reading and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-45hj-9x76-wp9g

  2. Revision 1 · created ·

    Published from osv record GHSA-45hj-9x76-wp9g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22819

Advisory: Outray has a Race Condition in the cli's webapp
IDs: CVE-2026-22819, GHSA-45hj-9x76-wp9g
Record: https://patchnext.com/advisories/cve-2026-22819 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: outray 0.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm outray: affected < 0.1.5; fixed in 0.1.5

## Suggested inspection (read-only)
- `npm ls outray --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on outray.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-45hj-9x76-wp9g (OSV record GHSA-45hj-9x76-wp9g lists affected ranges: npm outray >=0 <0.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-45hj-9x76-wp9g (GitHub-reviewed advisory GHSA-45hj-9x76-wp9g lists affected ranges: npm outray >=0 <0.1.5)

Commands are suggestions: review each one before running it.

Loading voting…