Skip to content

← Actionable
Critical, CVSS 9.4amended

Malicious website can execute commands on the local system through XSS in the OpenCode web UI

CVE-2026-22813GHSA-c83v-7274-4vgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencode-ai 1.1.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-22813: 0.91% estimated exploitation activity in the next 30 days; percentile 59.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A malicious website can abuse the server URL override feature of the OpenCode web UI to achieve cross-site scripting on http://localhost:4096. From there, it is possible to run arbitrary commands on the local system using the /pty/ endpoints provided by the OpenCode API. Code execution via OpenCode API - The OpenCode API has /pty/ endpoints that allow spawning arbitrary processes on the local machine. - When you run opencode in your terminal, OpenCode automatically starts an HTTP server on localhost:4096 that exposes the API along with a web interface. - JavaScript can make arbitrary same-origin fetch() requests to the /pty/ API endpoints. Therefore, JavaScript execution on http://localhost:4096 gets you code execution on local the machine. JavaScript execution on localhost:4096 The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-c83v-7274-4vgp

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-c83v-7274-4vgp

  4. Revision 1 · created ·

    Published from ghsa record GHSA-c83v-7274-4vgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22813

Advisory: Malicious website can execute commands on the local system through XSS in the OpenCode web UI
IDs: CVE-2026-22813, GHSA-c83v-7274-4vgp
Record: https://patchnext.com/advisories/cve-2026-22813 (revision 4, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opencode-ai 1.1.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm opencode-ai: affected < 1.1.10; fixed in 1.1.10

## Suggested inspection (read-only)
- `npm ls opencode-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opencode-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c83v-7274-4vgp (GitHub-reviewed advisory GHSA-c83v-7274-4vgp lists affected ranges: npm opencode-ai >=0 <1.1.10)
- Verified: https://osv.dev/vulnerability/GHSA-c83v-7274-4vgp (OSV record GHSA-c83v-7274-4vgp lists affected ranges: npm opencode-ai >=0 <1.1.10 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…