Skip to content

← Actionable
High, CVSS 8.8amended

vLLM affected by RCE via auto_map dynamic module loading during model initialization

CVE-2026-22807GHSA-2pc9-4j83-qjmr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.10.1, < 0.14.0
    Fixed in
    0.14.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-22807: 0.98% estimated exploitation activity in the next 30 days; percentile 62.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vLLM loads Hugging Face automap dynamic modules during model resolution without gating on trustremotecode, allowing attacker-controlled Python code in a model repo/path to execute at server startup. --- Impact An attacker who can influence the model repo/path (local directory or remote Hugging Face repo) can achieve arbitrary code execution on the vLLM host during model load. This happens before any request handling and does not require API access. --- Affected Versions All versions where vllm/modelexecutor/models/registry.py resolves automap entries with trygetclassfromdynamicmodule without checking trustremotecode (at least current main). --- Details During model resolution, vLLM unconditionally iterates automap entries from the model config and calls trygetclassfromdynamicmodule, which delegates to Transformers’ getclassfromdynamicmodule and executes the module code. This occurs even when trustremotecode is false, allowing a malicious model repo to embed code in a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2pc9-4j83-qjmr

  2. Revision 1 · created ·

    Published from osv record GHSA-2pc9-4j83-qjmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22807

Advisory: vLLM affected by RCE via auto_map dynamic module loading during model initialization
IDs: CVE-2026-22807, GHSA-2pc9-4j83-qjmr
Record: https://patchnext.com/advisories/cve-2026-22807 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.10.1, < 0.14.0; fixed in 0.14.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2pc9-4j83-qjmr (OSV record GHSA-2pc9-4j83-qjmr lists affected ranges: PyPI vllm >=0.10.1 <0.14.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2pc9-4j83-qjmr (GitHub-reviewed advisory GHSA-2pc9-4j83-qjmr lists affected ranges: PyPI vllm >=0.10.1 <0.14.0)

Commands are suggestions: review each one before running it.

Loading voting…