Skip to content

← Actionable
Medium, CVSS 5.9amended

hermes's raw options logging may disclose secrets passed in via subcommand options argument

CVE-2026-22798GHSA-jm5j-jfrm-hm23

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hermes 0.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI hermes

    Affected
    >= 0.8.1, <= 0.9.0
    Fixed in
    0.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N
EPSS
  • CVE-2026-22798: 0.17% estimated exploitation activity in the next 30 days; percentile 6.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Thanks, @thunze for reporting this! hermes subcommands take arbitrary options under the -O argument. These have been logged in raw form since https://github.com/softwarepub/hermes/commit/7f64f102e916c76dc44404b77ab2a80f5a4e59b1 in: https://github.com/softwarepub/hermes/blob/3a92f42b2b976fdbc2c49a621de6d665364a7cee/src/hermes/commands/cli.py#L66 If users provide sensitive data such as API tokens (e.g., via hermes deposit -O inveniordm.authtoken SECRET), these are written to the log file in plain text, making them available to whoever can access the log file. Impact As currently, hermes.log is not yet uploaded automatically as an artifact in CI, this vuln impacts: - local users working on shared access computers, where logs may be written to a commonly accessible file system - CI users whose CI logs are accessible to others, e.g., through group or organization rights Potentially, if the changes merged from https://github.com/softwarepub/ci-templates/pull/13 are merged into ci-templates…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jm5j-jfrm-hm23

  2. Revision 1 · created ·

    Published from osv record GHSA-jm5j-jfrm-hm23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22798

Advisory: hermes's raw options logging may disclose secrets passed in via subcommand options argument
IDs: CVE-2026-22798, GHSA-jm5j-jfrm-hm23
Record: https://patchnext.com/advisories/cve-2026-22798 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hermes 0.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI hermes: affected >= 0.8.1, <= 0.9.0; fixed in 0.9.1

## Suggested inspection (read-only)
- `python -m pip show hermes`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hermes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jm5j-jfrm-hm23 (OSV record GHSA-jm5j-jfrm-hm23 lists affected ranges: PyPI hermes >=0.8.1 <0.9.1 (fixed))
- Verified: https://github.com/advisories/GHSA-jm5j-jfrm-hm23 (GitHub-reviewed advisory GHSA-jm5j-jfrm-hm23 lists affected ranges: PyPI hermes >=0.8.1 <=0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…