vLLM has RCE In Video Processing
CVE-2026-22778GHSA-4r2x-xpjr-7cvv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.8.3, < 0.14.1
- Fixed in
- 0.14.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4r2x-xpjr-7cvv lists affected ranges: PyPI vllm >=0.8.3 <0.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4r2x-xpjr-7cvv lists affected ranges: PyPI vllm >=0.8.3 <0.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-22778: 18.29% estimated exploitation activity in the next 30 days; percentile 97.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A chain of vulnerabilities in vLLM allow Remote Code Execution (RCE): 1. Info Leak - PIL error messages expose memory addresses, bypassing ASLR 2. Heap Overflow - JPEG2000 decoder in OpenCV/FFmpeg has a heap overflow that lets us hijack code execution Result: Send a malicious video URL to vLLM Completions or Invocations for a video model - Execute arbitrary commands on the server Completely default vLLM instance directly from pip, or docker, does not have authentication so "None" privileges are required, but even with non-default api-key enabled configuration this exploit is feasible through invocations route that allows payload to execute pre-auth. Example heap target is provided, other heap targets can be exploited as well to achieve rce. Leak allows for simple ASLR bypass. Leak + heap overflow achieves RCE on versions prior to 0.14.1. Deployments not serving a video model are not affected. --- 1. Vulnerability Overview 1.1 The Bug: JPEG2000 cdef Box Heap Overflow The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4r2x-xpjr-7cvv
- Revision 2 · amended ·
Amended from osv record GHSA-4r2x-xpjr-7cvv
- Revision 1 · created ·
Published from ghsa record GHSA-4r2x-xpjr-7cvv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22778 Advisory: vLLM has RCE In Video Processing IDs: CVE-2026-22778, GHSA-4r2x-xpjr-7cvv Record: https://patchnext.com/advisories/cve-2026-22778 (revision 3, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.8.3, < 0.14.1; fixed in 0.14.1 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4r2x-xpjr-7cvv (GitHub-reviewed advisory GHSA-4r2x-xpjr-7cvv lists affected ranges: PyPI vllm >=0.8.3 <0.14.1) - Verified: https://osv.dev/vulnerability/GHSA-4r2x-xpjr-7cvv (OSV record GHSA-4r2x-xpjr-7cvv lists affected ranges: PyPI vllm >=0.8.3 <0.14.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…