Skip to content

← Actionable
High, CVSS 7.5amended

devalue vulnerable to denial of service due to memory/CPU exhaustion in devalue.parse

CVE-2026-22775GHSA-g2pg-6438-jwpf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm devalue

    Affected
    >= 5.1.0, < 5.6.2
    Fixed in
    5.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-22775: 0.63% estimated exploitation activity in the next 30 days; percentile 50.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the ArrayBuffer hydration expecting base64 encoded strings as input, but not checking the assumption before decoding the input. Details The parser's ArrayBuffer hydration logic does not properly validate input before processing. Specially crafted inputs can cause disproportionate memory allocation or CPU usage on the receiving system. Impact This is a denial of service vulnerability affecting systems that use devalue.parse to handle data from potentially untrusted sources. Affected systems should upgrade to patched versions immediately.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g2pg-6438-jwpf

  2. Revision 1 · created ·

    Published from osv record GHSA-g2pg-6438-jwpf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22775

Advisory: devalue vulnerable to denial of service due to memory/CPU exhaustion in devalue.parse
IDs: CVE-2026-22775, GHSA-g2pg-6438-jwpf
Record: https://patchnext.com/advisories/cve-2026-22775 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: devalue 5.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm devalue: affected >= 5.1.0, < 5.6.2; fixed in 5.6.2

## Suggested inspection (read-only)
- `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on devalue.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g2pg-6438-jwpf (OSV record GHSA-g2pg-6438-jwpf lists affected ranges: npm devalue >=5.1.0 <5.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-g2pg-6438-jwpf (GitHub-reviewed advisory GHSA-g2pg-6438-jwpf lists affected ranges: npm devalue >=5.1.0 <5.6.2)

Commands are suggestions: review each one before running it.

Loading voting…