Skip to content

← Actionable
Medium, CVSS 6.5amended

vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions

CVE-2026-22773GHSA-grg2-63fw-f2qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.6.4, < 0.12.0
    Fixed in
    0.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-22773: 0.44% estimated exploitation activity in the next 30 days; percentile 38.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. Details The vulnerability is triggered when the image processor encounters a 1x1 pixel image with shape (1, 1, 3) in HWC (Height, Width, Channel) format. Due to the ambiguous dimensions, the processor incorrectly assumes the image is in CHW (Channel, Height, Width) format with shape (3, H, W). This misinterpretation causes an incorrect calculation of the number of image patches, resulting in a fatal tensor split operation failure. Crash location: vllm/modelexecutor/models/idefics3.py line 672: The split() call fails because the computed numpatches value (17) does not match the actual tensor dimension (9): This unhandled exception terminates the EngineCore process, crashing the server. Affected Models…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-grg2-63fw-f2qr

  2. Revision 1 · created ·

    Published from osv record GHSA-grg2-63fw-f2qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22773

Advisory: vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions
IDs: CVE-2026-22773, GHSA-grg2-63fw-f2qr
Record: https://patchnext.com/advisories/cve-2026-22773 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.6.4, < 0.12.0; fixed in 0.12.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-grg2-63fw-f2qr (OSV record GHSA-grg2-63fw-f2qr lists affected ranges: PyPI vllm >=0.6.4 <0.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-grg2-63fw-f2qr (GitHub-reviewed advisory GHSA-grg2-63fw-f2qr lists affected ranges: PyPI vllm >=0.6.4 <0.12.0)

Commands are suggestions: review each one before running it.

Loading voting…