Envoy Extension Policy lua scripts injection causes arbitrary command execution
CVE-2026-22771GHSA-xrwg-mqj6-6m22
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/envoyproxy/gateway 1.6.2, 1.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/envoyproxy/gateway
- Affected
- >= 1.6.0-rc.0, < 1.6.2< 1.5.7
- Fixed in
- 1.6.2, 1.5.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xrwg-mqj6-6m22 lists affected ranges: Go github.com/envoyproxy/gateway >=1.6.0-rc.0 =0 <1.5.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-22771: 0.62% estimated exploitation activity in the next 30 days; percentile 49.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Envoy Gateway allows users to create Lua scripts that are executed by Envoy proxy using the EnvoyExtensionPolicy resource. Administrators can use Kubernetes RBAC to grant users the ability to create EnvoyExtensionPolicy resources. Lua scripts in policies are executed in two contexts: An EnvoyExtensionPolicy can be attached to Gateway and xRoute resources. Lua scripts in the policy will process traffic in that scope. Lua scripts are interpreted and run by the Envoy Gateway controller pod for validation purposes. Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. For example, the following EnvoyExtensionPolicy, when executed by Envoy proxy, will leak the proxy's XDS client certificates. This execution can lead to arbitrary code…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xrwg-mqj6-6m22
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22771 Advisory: Envoy Extension Policy lua scripts injection causes arbitrary command execution IDs: CVE-2026-22771, GHSA-xrwg-mqj6-6m22 Record: https://patchnext.com/advisories/cve-2026-22771 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/envoyproxy/gateway 1.6.2, 1.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/envoyproxy/gateway: affected >= 1.6.0-rc.0, < 1.6.2; < 1.5.7; fixed in 1.6.2, 1.5.7 ## Suggested inspection (read-only) - Go github.com/envoyproxy/gateway: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/envoyproxy/gateway. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xrwg-mqj6-6m22 (GitHub-reviewed advisory GHSA-xrwg-mqj6-6m22 lists affected ranges: Go github.com/envoyproxy/gateway >=1.6.0-rc.0 =0 <1.5.7) Commands are suggestions: review each one before running it.
Loading voting…