Skip to content

← Actionable
Medium, CVSS 6.5

ImageMagick releases an invalid pointer in BilateralBlur when memory allocation fails

CVE-2026-22770GHSA-39h3-g67r-7g3c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magick.net-q8-arm64 14.10.2; magick.net-q8-x86 14.10.2; magick.net-q16-hdri-anycpu 14.10.2; magick.net-q16-openmp-x64 14.10.2; magick.net-q16-anycpu 14.10.2; 14 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2026-22770: 0.39% estimated exploitation activity in the next 30 days; percentile 33.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The BilateralBlurImage method will allocate a set of double buffers inside AcquireBilateralTLS. But the last element in the set is not properly initialized. This will result in a release of an invalid pointer inside DestroyBilateralTLS when the memory allocation fails.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-39h3-g67r-7g3c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22770

Advisory: ImageMagick releases an invalid pointer in BilateralBlur when memory allocation fails
IDs: CVE-2026-22770, GHSA-39h3-g67r-7g3c
Record: https://patchnext.com/advisories/cve-2026-22770 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magick.net-q8-arm64 14.10.2; magick.net-q8-x86 14.10.2; magick.net-q16-hdri-anycpu 14.10.2; magick.net-q16-openmp-x64 14.10.2; magick.net-q16-anycpu 14.10.2; magick.net-q16-hdri-x86 14.10.2; magick.net-q16-hdri-openmp-arm64 14.10.2; magick.net-q16-hdri-arm64 14.10.2; magick.net-q16-x86 14.10.2; magick.net-q8-openmp-x64 14.10.2; magick.net-q16-hdri-openmp-x64 14.10.2; magick.net-q16-openmp-arm64 14.10.2; magick.net-q16-x64 14.10.2; magick.net-q8-x64 14.10.2; magick.net-q8-openmp-arm64 14.10.2; magick.net-q8-anycpu 14.10.2; magick.net-q16-openmp-x86 14.10.2; magick.net-q16-arm64 14.10.2; magick.net-q16-hdri-x64 14.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet magick.net-q8-arm64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q8-x86: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-hdri-anycpu: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-openmp-x64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-anycpu: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-hdri-x86: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-hdri-openmp-arm64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-hdri-arm64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-x86: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q8-openmp-x64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-hdri-openmp-x64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-openmp-arm64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-x64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q8-x64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q8-openmp-arm64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q8-anycpu: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-openmp-x86: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-arm64: affected < 14.10.2; fixed in 14.10.2
- NuGet magick.net-q16-hdri-x64: affected < 14.10.2; fixed in 14.10.2

## Suggested inspection (read-only)
- NuGet magick.net-q8-arm64: check the installed version with your package manager.
- NuGet magick.net-q8-x86: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-openmp-x64: check the installed version with your package manager.
- NuGet magick.net-q16-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-x86: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-openmp-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-x86: check the installed version with your package manager.
- NuGet magick.net-q8-openmp-x64: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-openmp-x64: check the installed version with your package manager.
- NuGet magick.net-q16-openmp-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-x64: check the installed version with your package manager.
- NuGet magick.net-q8-x64: check the installed version with your package manager.
- NuGet magick.net-q8-openmp-arm64: check the installed version with your package manager.
- NuGet magick.net-q8-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-openmp-x86: check the installed version with your package manager.
- NuGet magick.net-q16-arm64: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-x64: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magick.net-q8-arm64, magick.net-q8-x86, magick.net-q16-hdri-anycpu, magick.net-q16-openmp-x64, magick.net-q16-anycpu, magick.net-q16-hdri-x86, magick.net-q16-hdri-openmp-arm64, magick.net-q16-hdri-arm64, magick.net-q16-x86, magick.net-q8-openmp-x64, magick.net-q16-hdri-openmp-x64, magick.net-q16-openmp-arm64, magick.net-q16-x64, magick.net-q8-x64, magick.net-q8-openmp-arm64, magick.net-q8-anycpu, magick.net-q16-openmp-x86, magick.net-q16-arm64, magick.net-q16-hdri-x64.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-39h3-g67r-7g3c (GitHub-reviewed advisory GHSA-39h3-g67r-7g3c lists affected ranges: NuGet magick.net-q8-x64 >=0 =0 =0 =0 =0 =0 =0 =0 =0 =0 <14.10.2; NuGet…)

Commands are suggestions: review each one before running it.

Loading voting…