Spring Security Doesn't Correctly Include Servlet Path in Path Matching of XML Authorization Rules
CVE-2026-22754GHSA-4vrc-j85c-598c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-config 7.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-config
- Affected
- >= 7.0.0, <= 7.0.4
- Fixed in
- 7.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4vrc-j85c-598c lists affected ranges: Maven org.springframework.security:spring-security-config >=7.0.0 <=7.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-22754: 0.27% estimated exploitation activity in the next 30 days; percentile 18.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability in Spring Spring Security. If an application uses <sec:intercept-url servlet-path="/servlet-path" pattern="/endpoint/"/ to define the servlet path for computing a path matcher, then the servlet path is not included and the related authorization rules are not exercised. This can lead to an authorization bypass. This issue affects Spring Security: from 7.0.0 through 7.0.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4vrc-j85c-598c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22754 Advisory: Spring Security Doesn't Correctly Include Servlet Path in Path Matching of XML Authorization Rules IDs: CVE-2026-22754, GHSA-4vrc-j85c-598c Record: https://patchnext.com/advisories/cve-2026-22754 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-config 7.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-config: affected >= 7.0.0, <= 7.0.4; fixed in 7.0.5 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-config: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-config. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4vrc-j85c-598c (GitHub-reviewed advisory GHSA-4vrc-j85c-598c lists affected ranges: Maven org.springframework.security:spring-security-config >=7.0.0 <=7.0.4) Commands are suggestions: review each one before running it.
Loading voting…