Spring Security has Potential Security Misconfiguration when Using withIssuerLocation
CVE-2026-22748GHSA-cvc6-q2cp-2xhw
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-oauth2-jose
- Affected
- >= 6.3.0, <= 6.3.14>= 6.4.0, <= 6.4.14>= 6.5.0, <= 6.5.9>= 7.0.0, <= 7.0.4
- Fixed in
- 6.5.10, 7.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cvc6-q2cp-2xhw lists affected ranges: Maven org.springframework.security:spring-security-oauth2-jose >=6.3.0 =6.4.0 =6.5.0 =7.0.0 <=7.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-22748: 0.20% estimated exploitation activity in the next 30 days; percentile 10.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability in Spring Spring Security. When an application configures JWT decoding with NimbusJwtDecoder or NimbusReactiveJwtDecoder, it must configure an OAuth2TokenValidator<Jwt separately, for example by calling setJwtValidator. This issue affects Spring Security: from 6.3.0 through 6.3.14, from 6.4.0 through 6.4.14, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cvc6-q2cp-2xhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22748 Advisory: Spring Security has Potential Security Misconfiguration when Using withIssuerLocation IDs: CVE-2026-22748, GHSA-cvc6-q2cp-2xhw Record: https://patchnext.com/advisories/cve-2026-22748 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.security:spring-security-oauth2-jose 7.0.5, 6.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-oauth2-jose: affected >= 6.3.0, <= 6.3.14; >= 6.4.0, <= 6.4.14; >= 6.5.0, <= 6.5.9; >= 7.0.0, <= 7.0.4; fixed in 6.5.10, 7.0.5 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-oauth2-jose: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-oauth2-jose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cvc6-q2cp-2xhw (GitHub-reviewed advisory GHSA-cvc6-q2cp-2xhw lists affected ranges: Maven org.springframework.security:spring-security-oauth2-jose >=6.3.0 =6.4.0 =6.5.0 =7.0.0 <=7.0.4) Commands are suggestions: review each one before running it.
Loading voting…