Spring Security Vulnerable to User Attribute Enumeration when Using DaoAuthenticationProvider
CVE-2026-22746GHSA-vxf7-qj7q-83fh
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-core
- Affected
- >= 5.7.0, <= 5.7.22>= 5.8.0, <= 5.8.24>= 6.3.0, <= 6.3.15>= 6.4.0, <= 6.4.15>= 6.5.0, <= 6.5.9>= 7.0.0, <= 7.0.4
- Fixed in
- 6.5.10, 7.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxf7-qj7q-83fh lists affected ranges: Maven org.springframework.security:spring-security-core >=5.7.0 =5.8.0 =6.3.0 =6.4.0 =6.5.0 =7.0.0 <=7.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-22746: 0.21% estimated exploitation activity in the next 30 days; percentile 11.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability in Spring Spring Security. If an application is using the UserDetails#isEnabled, #isAccountNonExpired, or #isAccountNonLocked user attributes, to enable, expire, or lock users, then DaoAuthenticationProvider's timing attack defense can be bypassed for users who are disabled, expired, or locked. This issue affects Spring Security: from 5.7.0 through 5.7.22, from 5.8.0 through 5.8.24, from 6.3.0 through 6.3.15, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vxf7-qj7q-83fh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22746 Advisory: Spring Security Vulnerable to User Attribute Enumeration when Using DaoAuthenticationProvider IDs: CVE-2026-22746, GHSA-vxf7-qj7q-83fh Record: https://patchnext.com/advisories/cve-2026-22746 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.security:spring-security-core 7.0.5, 6.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-core: affected >= 5.7.0, <= 5.7.22; >= 5.8.0, <= 5.8.24; >= 6.3.0, <= 6.3.15; >= 6.4.0, <= 6.4.15; >= 6.5.0, <= 6.5.9; >= 7.0.0, <= 7.0.4; fixed in 6.5.10, 7.0.5 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vxf7-qj7q-83fh (GitHub-reviewed advisory GHSA-vxf7-qj7q-83fh lists affected ranges: Maven org.springframework.security:spring-security-core >=5.7.0 =5.8.0 =6.3.0 =6.4.0 =6.5.0 =7.0.0 <=7.0.4) Commands are suggestions: review each one before running it.
Loading voting…