Skip to content

← Actionable
High, CVSS 8.6

JSONPath Injection in Spring AI Vector Stores FilterExpressionConverter

CVE-2026-22729GHSA-rp9g-qx29-88cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.ai:spring-ai-vector-store 1.1.3, 1.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-22729: 0.54% estimated exploitation activity in the next 30 days; percentile 45.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A JSONPath injection vulnerability in Spring AI's AbstractFilterExpressionConverter allows authenticated users to bypass metadata-based access controls through crafted filter expressions. User-controlled input passed to FilterExpressionBuilder is concatenated into JSONPath queries without proper escaping, enabling attackers to inject arbitrary JSONPath logic and access unauthorized documents. This vulnerability affects applications using vector stores that extend AbstractFilterExpressionConverter for multi-tenant isolation, role-based access control, or document filtering based on metadata. The vulnerability occurs when user-supplied values in filter expressions are not escaped before being inserted into JSONPath queries. Special characters like ", ||, and && are passed through unescaped, allowing injection of arbitrary JSONPath logic that can alter the intended query semantics.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rp9g-qx29-88cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22729

Advisory: JSONPath Injection in Spring AI Vector Stores FilterExpressionConverter
IDs: CVE-2026-22729, GHSA-rp9g-qx29-88cp
Record: https://patchnext.com/advisories/cve-2026-22729 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.ai:spring-ai-vector-store 1.1.3, 1.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.ai:spring-ai-vector-store: affected >= 1.1.0-M1, < 1.1.3; < 1.0.4; fixed in 1.0.4, 1.1.3

## Suggested inspection (read-only)
- Maven org.springframework.ai:spring-ai-vector-store: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.ai:spring-ai-vector-store.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rp9g-qx29-88cp (GitHub-reviewed advisory GHSA-rp9g-qx29-88cp lists affected ranges: Maven org.springframework.ai:spring-ai-vector-store >=1.1.0-M1 =0 <1.0.4)

Commands are suggestions: review each one before running it.

Loading voting…