vm2 has a Sandbox Escape
CVE-2026-22709GHSA-99p7-6v5w-7xg8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.10.1
- Fixed in
- 3.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-99p7-6v5w-7xg8 lists affected ranges: npm vm2 >=0 <=3.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-99p7-6v5w-7xg8 lists affected ranges: npm vm2 >=0 <3.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-22709: 1.27% estimated exploitation activity in the next 30 days; percentile 69.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In vm2 for version 3.10.0, Promise.prototype.then Promise.prototype.catch callback sanitization can be bypassed. This allows attackers to escape the sandbox and run arbitrary code. In lib/setup-sandbox.js, the callback function of localPromise.prototype.then is sanitized, but globalPromise.prototype.then is not sanitized. The return value of async functions is globalPromise object.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-99p7-6v5w-7xg8
- Revision 2 · amended ·
Amended from osv record GHSA-99p7-6v5w-7xg8
- Revision 1 · created ·
Published from ghsa record GHSA-99p7-6v5w-7xg8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22709 Advisory: vm2 has a Sandbox Escape IDs: CVE-2026-22709, GHSA-99p7-6v5w-7xg8 Record: https://patchnext.com/advisories/cve-2026-22709 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.10.1; fixed in 3.10.2 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-99p7-6v5w-7xg8 (GitHub-reviewed advisory GHSA-99p7-6v5w-7xg8 lists affected ranges: npm vm2 >=0 <=3.10.1) - Verified: https://osv.dev/vulnerability/GHSA-99p7-6v5w-7xg8 (OSV record GHSA-99p7-6v5w-7xg8 lists affected ranges: npm vm2 >=0 <3.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…