Skip to content

← Actionable
Low, CVSS 2.1amended

Strapi: Password Reset Does Not Revoke Existing Refresh Sessions

CVE-2026-22706GHSA-hvp3-26wx-g2w4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-users-permissions 5.33.3; @strapi/admin 5.33.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-22706: 0.34% estimated exploitation activity in the next 30 days; percentile 27.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary of CVE-2026-22706 Vulnerability Details - CVE: CVE-2026-22706 - CVSS v3.1 Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N (2.1 — Low) - Affected Versions: @strapi/admin and @strapi/plugin-users-permissions <=5.33.2 - How to Patch: Immediately update your Strapi to =5.33.3 Description of CVE-2026-22706 In Strapi versions prior to 5.33.3, changing or resetting a user's password did not invalidate the user's existing refresh-token sessions by default. The refresh-token invalidation step in the users-permissions and admin authentication controllers was conditional on a caller-supplied deviceId. When a password change or reset request did not include a deviceId, no refresh tokens were revoked, leaving every prior session active. An attacker who had previously obtained a refresh token could continue minting new access tokens after the legitimate user reset their password, allowing persistent unauthorized access for the lifetime of the refresh token (up to 30…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hvp3-26wx-g2w4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hvp3-26wx-g2w4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22706

Advisory: Strapi: Password Reset Does Not Revoke Existing Refresh Sessions
IDs: CVE-2026-22706, GHSA-hvp3-26wx-g2w4
Record: https://patchnext.com/advisories/cve-2026-22706 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-users-permissions 5.33.3; @strapi/admin 5.33.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/plugin-users-permissions: affected <= 5.33.2; fixed in 5.33.3
- npm @strapi/admin: affected <= 5.33.2; fixed in 5.33.3

## Suggested inspection (read-only)
- `npm ls @strapi/plugin-users-permissions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @strapi/admin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/plugin-users-permissions, @strapi/admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hvp3-26wx-g2w4 (OSV record GHSA-hvp3-26wx-g2w4 lists affected ranges: npm @strapi/admin >=0 =0 <5.33.3 (fixed))
- Verified: https://github.com/advisories/GHSA-hvp3-26wx-g2w4 (GitHub-reviewed advisory GHSA-hvp3-26wx-g2w4 lists affected ranges: npm @strapi/admin >=0 =0 <=5.33.2)

Commands are suggestions: review each one before running it.

Loading voting…