Skip to content

← Actionable
High, CVSS 8.0amended

HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover

CVE-2026-22704GHSA-3fm2-xfq7-7778

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 25.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-22704: 1.03% estimated exploitation activity in the next 30 days; percentile 63.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Stored XSS Leading to Account Takeover Details The Exploit Chain: 1.Upload: The attacker uploads an .html file containing a JavaScript payload. 2.Execution: A logged-in administrator is tricked into visiting the URL of this uploaded file. 3.Token Refresh: The JavaScript payload makes a fetch request to the /system/api/refreshAccessToken endpoint. Because the administrator is logged in, their browser automatically attaches the haxcmsrefreshtoken cookie to this request. 4.JWT Theft: The server validates the refresh token and responds with a new, valid JWT access token in the JSON response. 5.Exfiltration: The JavaScript captures this new JWT from the response and sends it to an attacker-controlled server. 6.Account Takeover: The attacker now possesses a valid administrator JWT and can take full control of the application. Vulnerability recurrence: <img width="1198" height="756" alt="image" src="https://github.com/user-attachments/assets/7062d542-702e-4cbe-8493-da0f71e790c3" /…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3fm2-xfq7-7778

  2. Revision 1 · created ·

    Published from osv record GHSA-3fm2-xfq7-7778

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22704

Advisory: HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover
IDs: CVE-2026-22704, GHSA-3fm2-xfq7-7778
Record: https://patchnext.com/advisories/cve-2026-22704 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 25.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @haxtheweb/haxcms-nodejs: affected >= 11.0.6, < 25.0.0; fixed in 25.0.0

## Suggested inspection (read-only)
- `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @haxtheweb/haxcms-nodejs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3fm2-xfq7-7778 (OSV record GHSA-3fm2-xfq7-7778 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=11.0.6 <25.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3fm2-xfq7-7778 (GitHub-reviewed advisory GHSA-3fm2-xfq7-7778 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=11.0.6 <25.0.0)

Commands are suggestions: review each one before running it.

Loading voting…