WeKnora has Command Injection in MCP stdio test
CVE-2026-22688GHSA-78h3-63c4-5fqc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/Tencent/WeKnora 0.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.2.5
- Fixed in
- 0.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-78h3-63c4-5fqc lists affected ranges: Go github.com/Tencent/WeKnora >=0 <0.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-22688: 1.94% estimated exploitation activity in the next 30 days; percentile 80.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability Description --- Vulnerability Overview This issue is a command injection vulnerability (CWE-78) that allows authenticated users to inject stdioconfig.command/args into MCP stdio settings, causing the server to execute subprocesses using these injected values. The root causes are as follows: - Missing Security Filtering: When transporttype=stdio, there is no validation on stdioconfig.command/args, such as allowlisting, enforcing fixed paths/binaries, or blocking dangerous options. - Functional Flaw (Trust Boundary Violation): The command/args stored as "service configuration data" are directly used in the /test execution flow and connected to execution sinks without validation. - Lack of Authorization Control: This functionality effectively allows "process execution on the server" (an administrative operation), yet no administrator-only permission checks are implemented in the code (accessible with Bearer authentication only). Vulnerable Code 1. API Route Registration…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-78h3-63c4-5fqc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22688 Advisory: WeKnora has Command Injection in MCP stdio test IDs: CVE-2026-22688, GHSA-78h3-63c4-5fqc Record: https://patchnext.com/advisories/cve-2026-22688 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/Tencent/WeKnora 0.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/Tencent/WeKnora: affected < 0.2.5; fixed in 0.2.5 ## Suggested inspection (read-only) - Go github.com/Tencent/WeKnora: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/Tencent/WeKnora. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-78h3-63c4-5fqc (GitHub-reviewed advisory GHSA-78h3-63c4-5fqc lists affected ranges: Go github.com/Tencent/WeKnora >=0 <0.2.5) Commands are suggestions: review each one before running it.
Loading voting…