Skip to content

← Actionable
Critical, CVSS 10.0amended

enclave-vm Vulnerable to Sandbox Escape via Host Error Prototype Chain

CVE-2026-22686GHSA-7qm7-455j-5p63

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (enclave-vm 2.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-22686: 0.75% estimated exploitation activity in the next 30 days; percentile 55.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A critical sandbox escape vulnerability exists in enclave-vm (affected: < 2.6.0, patched: 2.7.0) that can allow untrusted, sandboxed JavaScript to execute arbitrary code in the host Node.js runtime. When a tool invocation fails, enclave-vm exposes a host-side Error object to sandboxed code. This Error object retains its host realm prototype chain, which can be traversed to reach the host Function constructor: Error instance → Error.prototype → Error constructor → Function constructor With access to the host Function constructor, an attacker can compile and execute arbitrary JavaScript in the host context — bypassing the sandbox boundary and potentially gaining access to sensitive resources such as process.env, filesystem, and network. This breaks enclave-vm’s core security guarantee of isolating untrusted code. --- Ecosystem Impact (FrontMCP / CodeCall) FrontMCP is a TypeScript-first framework for building MCP servers, and the CodeCall plugin enables models to orchestrate large…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7qm7-455j-5p63

  2. Revision 2 · amended ·

    Amended from osv record GHSA-7qm7-455j-5p63

  3. Revision 1 · created ·

    Published from ghsa record GHSA-7qm7-455j-5p63

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22686

Advisory: enclave-vm Vulnerable to Sandbox Escape via Host Error Prototype Chain
IDs: CVE-2026-22686, GHSA-7qm7-455j-5p63
Record: https://patchnext.com/advisories/cve-2026-22686 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: enclave-vm 2.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm enclave-vm: affected < 2.7.0; fixed in 2.7.0

## Suggested inspection (read-only)
- `npm ls enclave-vm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on enclave-vm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7qm7-455j-5p63 (GitHub-reviewed advisory GHSA-7qm7-455j-5p63 lists affected ranges: npm enclave-vm >=0 <2.7.0)
- Verified: https://osv.dev/vulnerability/GHSA-7qm7-455j-5p63 (OSV record GHSA-7qm7-455j-5p63 lists affected ranges: npm enclave-vm >=0 <2.7.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…