Skip to content

← Actionable
High, CVSS 8.9amended

Fickling vulnerable to detection bypass due to "builtins" blindness

CVE-2026-22612GHSA-h4rm-mm56-xf63

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fickling 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fickling

    Affected
    <= 0.1.6
    Fixed in
    0.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-22612: 0.32% estimated exploitation activity in the next 30 days; percentile 25.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

#Fickling's assessment Fickling started emitting AST nodes for builtins imports in order to match them during analysis (https://github.com/trailofbits/fickling/commit/9f309ab834797f280cb5143a2f6f987579fa7cdf). Original report Summary Fickling works by Pickle bytecode -- AST -- Security analysis However while going from bytecode to AST, some import nodes are removed which blinds the security analysis fickling/fickling/fickle.py Here we see that no import nodes are emitted for builtins However builtins is marked as an unsafe import fickling/fickling/analysis.py But because there are no import nodes for builtins (they werent emitted when making the AST), the security scanner is effectively blind. This can allow for security bypasses like this poc.py (script to create payload) This creates a pickle file which imports the OS module using import which is a part of builtins. if the security scanner wasnt blinded it would have been flagged immidiately. However now fickling sees the pickle…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h4rm-mm56-xf63

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h4rm-mm56-xf63

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22612

Advisory: Fickling vulnerable to detection bypass due to "builtins" blindness
IDs: CVE-2026-22612, GHSA-h4rm-mm56-xf63
Record: https://patchnext.com/advisories/cve-2026-22612 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fickling 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fickling: affected <= 0.1.6; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show fickling`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fickling.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h4rm-mm56-xf63 (OSV record GHSA-h4rm-mm56-xf63 lists affected ranges: PyPI fickling >=0 <0.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-h4rm-mm56-xf63 (GitHub-reviewed advisory GHSA-h4rm-mm56-xf63 lists affected ranges: PyPI fickling >=0 <=0.1.6)

Commands are suggestions: review each one before running it.

Loading voting…