Skip to content

← Actionable
High, CVSS 8.5amended

Angular has XSS Vulnerability via Unsanitized SVG Script Attributes

CVE-2026-22610GHSA-jrmj-c5cx-3cw6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @angular/compiler

    Affected
    >= 21.1.0-next.0, < 21.1.0-rc.0>= 21.0.0-next.0, < 21.0.7>= 20.0.0-next.0, < 20.3.16>= 19.0.0-next.0, < 19.2.18<= 18.2.14
    Fixed in
    21.1.0-rc.0, 20.3.16, 21.0.7, 19.2.18
  • npm @angular/core

    Affected
    >= 21.1.0-next.0, < 21.1.0-rc.0>= 21.0.0-next.0, < 21.0.7>= 20.0.0-next.0, < 20.3.16>= 19.0.0-next.0, < 19.2.18<= 18.2.14
    Fixed in
    21.1.0-rc.0, 20.3.16, 21.0.7, 19.2.18

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-jrmj-c5cx-3cw6 lists affected ranges: npm @angular/compiler >=21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jrmj-c5cx-3cw6 lists affected ranges: npm @angular/compiler >=21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-22610: 0.44% estimated exploitation activity in the next 30 days; percentile 38.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script elements as a Resource URL context. In a standard security model, attributes that can load and execute code (like a script's source) should be strictly validated. However, because the compiler does not classify these specific SVG attributes correctly, it allows attackers to bypass Angular's built-in security protections. When template binding is used to assign user-controlled data to these attributes for example, <script [attr.href]="userInput" the compiler treats the value as a standard string or a non-sensitive URL rather than a resource link. This enables an attacker to provide a malicious payload, such as a data:text/javascript URI or a link to an external malicious script. Impact When successfully exploited, this vulnerability allows for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jrmj-c5cx-3cw6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jrmj-c5cx-3cw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22610

Advisory: Angular has XSS Vulnerability via Unsanitized SVG Script Attributes
IDs: CVE-2026-22610, GHSA-jrmj-c5cx-3cw6
Record: https://patchnext.com/advisories/cve-2026-22610 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @angular/compiler 21.1.0-rc.0, 21.0.7, 20.3.16, 19.2.18; @angular/core 21.1.0-rc.0, 21.0.7, 20.3.16, 19.2.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @angular/compiler: affected >= 21.1.0-next.0, < 21.1.0-rc.0; >= 21.0.0-next.0, < 21.0.7; >= 20.0.0-next.0, < 20.3.16; >= 19.0.0-next.0, < 19.2.18; <= 18.2.14; fixed in 21.1.0-rc.0, 20.3.16, 21.0.7, 19.2.18
- npm @angular/core: affected >= 21.1.0-next.0, < 21.1.0-rc.0; >= 21.0.0-next.0, < 21.0.7; >= 20.0.0-next.0, < 20.3.16; >= 19.0.0-next.0, < 19.2.18; <= 18.2.14; fixed in 21.1.0-rc.0, 20.3.16, 21.0.7, 19.2.18

## Suggested inspection (read-only)
- `npm ls @angular/compiler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @angular/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/compiler, @angular/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jrmj-c5cx-3cw6 (OSV record GHSA-jrmj-c5cx-3cw6 lists affected ranges: npm @angular/compiler >=21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14)
- Verified: https://github.com/advisories/GHSA-jrmj-c5cx-3cw6 (GitHub-reviewed advisory GHSA-jrmj-c5cx-3cw6 lists affected ranges: npm @angular/compiler >=21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 =21.1.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14)

Commands are suggestions: review each one before running it.

Loading voting…