Fickling has Static Analysis Bypass via Incomplete Dangerous Module Blocklist
CVE-2026-22609GHSA-q5qq-mvfm-j35x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fickling 0.1.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fickling
- Affected
- <= 0.1.6
- Fixed in
- 0.1.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q5qq-mvfm-j35x lists affected ranges: PyPI fickling >=0 <0.1.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q5qq-mvfm-j35x lists affected ranges: PyPI fickling >=0 <=0.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-22609: 0.63% estimated exploitation activity in the next 30 days; percentile 50.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
#Fickling's assessment ctypes, importlib, runpy, code and multiprocessing were added the list of unsafe imports (https://github.com/trailofbits/fickling/commit/9a2b3f89bd0598b528d62c10a64c1986fcb09f66, https://github.com/trailofbits/fickling/commit/eb299b453342f1931c787bcb3bc33f3a03a173f9, https://github.com/trailofbits/fickling/commit/29d5545e74b07766892c1f0461b801afccee4f91, https://github.com/trailofbits/fickling/commit/b793563e60a5e039c5837b09d7f4f6b92e6040d1, https://github.com/trailofbits/fickling/commit/b793563e60a5e039c5837b09d7f4f6b92e6040d1). Original report Summary The unsafeimports() method in Fickling's static analyzer fails to flag several high-risk Python modules that can be used for arbitrary code execution. Malicious pickles importing these modules will not be detected as unsafe, allowing attackers to bypass Fickling's primary static safety checks. Details In fickling/fickle.py lines 866-884, the unsafeimports() method checks imported modules against a hardcoded…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q5qq-mvfm-j35x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q5qq-mvfm-j35x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22609 Advisory: Fickling has Static Analysis Bypass via Incomplete Dangerous Module Blocklist IDs: CVE-2026-22609, GHSA-q5qq-mvfm-j35x Record: https://patchnext.com/advisories/cve-2026-22609 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fickling 0.1.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fickling: affected <= 0.1.6; fixed in 0.1.7 ## Suggested inspection (read-only) - `python -m pip show fickling`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fickling. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q5qq-mvfm-j35x (OSV record GHSA-q5qq-mvfm-j35x lists affected ranges: PyPI fickling >=0 <0.1.7 (fixed)) - Verified: https://github.com/advisories/GHSA-q5qq-mvfm-j35x (GitHub-reviewed advisory GHSA-q5qq-mvfm-j35x lists affected ranges: PyPI fickling >=0 <=0.1.6) Commands are suggestions: review each one before running it.
Loading voting…