Skip to content

← Actionable
Medium, CVSS 6.5

Gogs has a Denial of Service issue

CVE-2026-22592GHSA-cr88-6mqm-4g57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.13.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-22592: 0.37% estimated exploitation activity in the next 30 days; percentile 31.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. Details If GetMirrorByRepoID fails, the error log dereferencing null pointer. This happens if the repository no longer exits. https://github.com/gogs/gogs/blob/4cc83c498b6ae59356a04912d68a932165bad5e6/internal/database/mirror.go#L333-L337 if err != nil m is alwasa nil https://github.com/gogs/gogs/blob/4cc83c498b6ae59356a04912d68a932165bad5e6/internal/database/mirror.go#L269-L278 PoC Spam mirror-sync on repo and delete this repo code python spam mirror-sync Impact Denial of Service server crash.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cr88-6mqm-4g57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22592

Advisory: Gogs has a Denial of Service issue
IDs: CVE-2026-22592, GHSA-cr88-6mqm-4g57
Record: https://patchnext.com/advisories/cve-2026-22592 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.13.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gogs.io/gogs: affected <= 0.13.3; fixed in 0.13.4

## Suggested inspection (read-only)
- Go gogs.io/gogs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gogs.io/gogs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cr88-6mqm-4g57 (GitHub-reviewed advisory GHSA-cr88-6mqm-4g57 lists affected ranges: Go gogs.io/gogs >=0 <=0.13.3)

Commands are suggestions: review each one before running it.

Loading voting…