Skip to content

← Actionable
High, CVSS 7.5

Spree API has Unauthenticated IDOR - Guest Address

CVE-2026-22589GHSA-3ghg-3787-w2xr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree_core 5.2.5, 5.1.9, 5.0.7, 4.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems spree_core

    Affected
    >= 4.0.0, < 4.10.2>= 5.0.0, < 5.0.7>= 5.1.0, < 5.1.9>= 5.2.0, < 5.2.5
    Fixed in
    5.2.5, 5.1.9, 4.10.2, 5.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-22589: 0.45% estimated exploitation activity in the next 30 days; percentile 39.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An Unauthenticated Insecure Direct Object Reference (IDOR) vulnerability was identified that allows an unauthenticated attacker to access guest address information without supplying valid credentials or session cookies. Details During testing, it was observed that all guest users can make an unauthenticated request to retrieve address data belonging to other guest users by manipulating object identifiers. The attacker would need to know the storefront URL structure to perform this attack (which can be learnt after creating a registered user account). Affected Component(s) Address Edit endpoint: /addresses/{addressId}/edit Root Cause - Faulty authorization check in CanCanCan Ability class: the user object in Spree::Ability class for guest users is a Spree.userclass.new object. Addresses endpoint to access it is part of the spreestorefront gem. Headless builds using APIs are not affected, as the Addresses endpoint there is only for registered users, and records are scoped to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3ghg-3787-w2xr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22589

Advisory: Spree API has Unauthenticated IDOR - Guest Address
IDs: CVE-2026-22589, GHSA-3ghg-3787-w2xr
Record: https://patchnext.com/advisories/cve-2026-22589 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spree_core 5.2.5, 5.1.9, 5.0.7, 4.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems spree_core: affected >= 4.0.0, < 4.10.2; >= 5.0.0, < 5.0.7; >= 5.1.0, < 5.1.9; >= 5.2.0, < 5.2.5; fixed in 5.2.5, 5.1.9, 4.10.2, 5.0.7

## Suggested inspection (read-only)
- RubyGems spree_core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spree_core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3ghg-3787-w2xr (GitHub-reviewed advisory GHSA-3ghg-3787-w2xr lists affected ranges: RubyGems spree_core >=4.0.0 =5.0.0 =5.1.0 =5.2.0 <5.2.5)

Commands are suggestions: review each one before running it.

Loading voting…